Can't get printers to download onto my windows 7 home premium!!

  Chazow 02:00 12 May 2014
Locked

Hi guys

This is one thats been really confusing as well as irritating for over a month!

I am running windows 7 home premium on a Pryon (Pry-2600E) computer. We've never had any issues until recently but we bought a printer (from Officeworks) which was a Brother MFC-J4510DW, I tried multiple times over a period of three weeks to get it working. I even contacted brother who informed me after some checked my Windows Image Acquisition Tool was not performing properly (turned off after twenty seconds) however when I contacted Windows they made me do all the same troubleshooting with the printer I had already done, told me to manually download the drivers for the printer which I also had tried repeatedly, and then they told me I'd have to PAY to resolve the issue.

My computer had also started coming up with a blue screen on every setup since trying to set up the first printer.. which said "driverIRQLnotlessorequalto" and tells me its crash dumping memory… under this comes up the following

Technical information:

* STOP: 0x000000D1 (0x0000000000000010, 0x0000000000000002, 0x0000000000000000, 0xFFFFF8801655566)

* ndis.sys - Address FFFFF8001655566 base at FFFFF88001626000, DateStamp 5034f6b2

I'm pretty sure this is related to the printer as the fact that this started happening only when I've tried to install the printer

I have run command prompt and run sfc/scannow no errors appear.

Anyway, I tried everything I was told but nothing worked the printer would install pretty much to the end then ask me to plug in the usb cable for the printer (I have checked all my usb hubs and know they all work and that this is not simply a usb cable error because the computer makes the connected noise, however doesn't say that anythings been plugged in.

Yesterday after much ado, I returned the brother printer to Officeworks for a new printer, Which is an Epson WF-3520…. SAME ISSUE. Plugged in the Usb cable and the next button stays greyed out. however when I go under printers and devices the printer is listed both as unspecified and also under printers but when I try to print it tries to fax it.. it does also say (FAX) beside its model no.

I've never really installed anything on my 13" macbook pro however I was wondering if its my imagination no printers are working, I mean it's not like i'm buying a cheap printer both printers were AUD $150

Anyway after five minutes the printer was up and running on my macbook but i'm still getting the blue screen on my computer, even though after removing all of the brother product it went away, but after trying to install the Epson it has returned on startup.

If anyone can offer advice it would be greatly appreciated

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

11 best portfolio websites for designers and artists

Office for Mac buying guide: Price, Office 2017 rumours & new features

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?