Can't access my Flash Drive

  Bertie B 17:15 04 Aug 2009

I have been using a 2gb bytstore Flash Drive for well over a year now - contains my briefcase files - logins, etc.

Suddenly, when I plug it in the system makes the usual noise as it connects but I can't see it in the Windows directory to access the files.

In Device Manager, under USB Mass Storage Device, the following info is displayed:-

"Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)

To fix this problem, unplug this device from your computer and then plug it in again.

Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available."

Now as I am running Vista - strictly speaking it should not be necessary to click on "Safely Remove Hardware" but if you do you can see the flash drive listed as Drive G: but you can't see it in the Root Directory to access it. I've tried the safely unistall routine and then plugging it back in but that does not clear the matter. I've tried sending the data to Microsoft but get no solution returned. If I plug in a different Flash Drive - that works OK and if I plug in the offending Flash Drive into my Descktop PC - It installs ok and I can access the files from the root directory normally. JUST CAN'T SO IT ON MY LAPTOP ANYMORE!!

Any suggestions would gratefully received, please!

  Peter 09:39 05 Aug 2009


As you appear to be able to access your files from the 2GB Bytstore Flash Drive on your desktop PC it would be best if you back them up before the flash drive gives up the ghost.

If you have another spare flash drive, with sufficient capacity, you could also copy all the files across to it, on the desktop PC, and see if that solves your problem. If this works okay on your laptop PC it would further indicate a problem with the 2GB Bytstore Flash Drive.

Even under Vista I would ALWAYS recommend to "Safely Remove Hardware".

Once you have retrieved all your files from the 2GB Bytstore Flash Drive you could try formatting it to see if that makes it work okay, but I would still be somewhat suspicious of it.


  Bertie B 11:05 05 Aug 2009

Thanks for the advice Peter.

I too was suspicious that the flash drive might be on the way out so backed up my files yesterday.

Worth re-formatting though - will give it a try.



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

How modern book design was influenced by illustrated manuscripts

Best Black Friday Apple Deals 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)