Yet another ICS topic

  nondiscere 22:40 11 Nov 2006
Locked

I have reviewed many ICS issue forums, and none have worked for me. In one part of the house, I have a clearwire modem connected to a wireless router. There is a desktop that connects directly to the router. It can access the internet just fine. In another part of the house, I have a laptop with a wireless card and an ethernet NIC. It connects to the Internet just fine. The problem is that I want to connect to the Internet on my more powerful desktop (through the laptop's wireless connection). File and printer sharing works swimmingly between the two computers, and I do have ICS enabled under the wireless connections tcp/ip settings.

I have tried all manner of things, including manually entering IP addresses or automatically configuring them. When I set the 3 NIC's (wireless card, laptop network card, desktop network card) to obtain ip automatically, the wireless card configures just fine. This is also the only way I can access the Internet. But the other two are assigned weird IP's. 169.254.185.116 and the wrong subnet on the laptop's network card and 0.0.0.0 on the desktop. So I tried manually configuring the wireless networking card's IP info, copying the correct information from the auto-ip-info exactly, and I can no longer access the internet. One thing that changes when I do this is that in ipconfig /all, dhcp is no longer enabled. My router is set to be a dhcp server.

The other advantage to manually setting all card's IPs is that the "limited or no connectivity" icon goes away from the taskbar (but file/printer sharing works fine whether this is there or not). I will copy and paste all the ipconfig info for the two computers after manually entering IP's. Let me know if you need any more info.

For the laptop>>>>>>>>>>>

C:\Documents and Settings\Zac>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : zactop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : National Semiconductor DP83815-Based PCI Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-03-0D-04-FA-52
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.4
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : D-Link AirPlus Xtreme G DWL-G650 Adapter
Physical Address. . . . . . . . . : 00-0D-88-B8-75-5E
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1

C:\Documents and Settings\Zac>

For the desktop>>>>>>>>>>

C:\Documents and Settings\Zac>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : emperorqin
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 PL Network Connection
Physical Address. . . . . . . . . : 00-16-17-BE-2D-95
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1

C:\Documents and Settings\Zac>



Thanks a lot.

  Strawballs 23:16 11 Nov 2006

Would it not be easier getting a wireless adapter (USB or PCI) for your desktop and accessing your wireless roter directly

  mgmcc 00:22 12 Nov 2006

The IP addressing for the Laptop's "Local Area Connection" is definitely wrong for Internet Connection Sharing. You should have enabled ICS on the laptop's actual internet connection which, in your case, is its Wireless adapter. When you do this, Windows should automatically configure your Local Area Connection with the fixed IP address of 192.168.0.1 and subnet mask 255.255.255.0 There will be no Default Gateway or DNS server addresses allocated because that adapter is not going online - it is routing internet traffic to/from the "client" PC.

The "Client" PC should be set to get its IP address automatically, which it does by DHCP from the Host PC. It will also get an address in the 192.168.0.0 subnet.

At the moment, your laptop and the PC connected to it will share files/printers because they are in the same subnet, but the configuration is wrong for ICS.

Disable ICS on the laptop's Wireless Adapter (which is where it should be set up), set the Local Area Connection to get its IP and DNS server addresses automatically, then re-enable ICS on the Wireless Adapter so that *WINDOWS* configures the Local Area Connection with its fixed IP address of 192.168.0.1

...or as Strawballs suggests, connect the second PC wirelessly too ;)

  Strawballs 09:51 12 Nov 2006

You have ticked as resolved, in the interest of other people who may be having the same problem and were following this thread can you indicate how it was resolved thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?