XP TweakUI has amnesia!

  Chris the Ancient 18:14 04 Jul 2004

Don't know if anyone has had this problem!

I have just bought Der Boss a new machine and got it all set up and running fine.


Once in a while, TweakUI 'forgets' that I set the 'Autologon' for 'Automatically logon at system startup', and hides in the corner and sulks until I re-enable it. So I have to reset it 'On' again.

Anyone else had/cured this problem?


  VoG II 18:22 04 Jul 2004

No but there is another way. Start, Run, type

control userpasswords2

and click OK.

Untick "Users must enter a username and password to use this computer".

  Chris the Ancient 18:33 04 Jul 2004

Too quick!

She's using the machine at the moment! I'll try a little later when she's pouring chilled white and report back then.


  Chris the Ancient 18:36 04 Jul 2004

Coz I'm stuck in brain-using mode for a moment...

Any idea how or why your suggestion works? I'm interested when people come up with these new (to me ) ideas. }0)

  VoG II 18:39 04 Jul 2004

I presume that it makes the same change to the registry that TweakUI does. But I don't actually know!

Of course, only time will reveal whether control userpasswords2 has amnesia as well ;o)

  VoG II 18:43 04 Jul 2004

Well, now I know and here's a third method click here if you fancy a trip to the registry.

  Chris the Ancient 18:50 04 Jul 2004


I like the userpasswords2 most - at the moment. As you say, time will tell if amnesia strikes there as well!

I shall mark as resolved - for now - and rethread if needed.

Megathanks, Oh wise and wonderful sage!

I think we shall have to use one of my favourite words for you... (perhaps as a new handle!)

VoG™ aka... Thaumaturge!


  QuickHare 18:55 04 Jul 2004

I read the page VoG™ gave, and was surprised the password is stored to plainly in the Registry! I know it's a security risk to use AutoLogin, but I didn't know it was even more of a risk by the way it stores it!

  Chris the Ancient 18:57 22 Jul 2004

Hmmm... Userpasswords2 locked me out coz there was no password! (Thank goodness for a system backup!)

Eventually (I've been s-o-o-o busy - and it wasn't a drop dead thing), I got time to really attack the KB article pointed to by VoG™.

My problem seems to stem from the fact that there was no DefaultPassword registry key even listed; so I made one with a null value and all is now well. The AutoAdminLogon then stays at 1 and works. With no DefaultPassword key set, it keeps reverting to 0. Interesting!

So, a rather belated added thanks to VoG™ for pointing me there and I now have a more peaceful life!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?