XP System restore doesn't

  skeletal 18:01 10 Jan 2004

Hi All

I have just been trying a new program (virtualCD) but it was not doing what I wanted. I tried an uninstall, then reinstall, but still not correct.

Now the main question! Before I did all this, I made a system restore point; so I then tried to get back to this. I got a message saying restore incomplete because no changes have been made to the computer. Oh, what! Only a few hundred!

I then tried lots of restore points going back weeks. Still the same.

I have looked in previous posts and it looks like others have had this problem; but I have never had this happen before, and I use system restore loads.

Needless to say, all processes are running correctly, there is loads of disc space and I tried it in safe mode.

Is it true that turning off SR; rebooting; turning back on, will make it work again?

Can I save the hundreds of restore points first; or after the "cure" will a pointer be reset so my restore points will be lost for ever?

Any thoughts as to why this has happened in the first place?

Ta for any help/thoughts.

Skeletal (now faced with much registry editing!)

  hugh-265156 18:26 10 Jan 2004

if you disable system restore ad re enable it then yes all your restore points will be gone apart from a checkpoint that is created when re enabled.

"hundreds of restore points" really? this will take up quite a bit of your disc space.

do you have service pk 1 installed? i had similar problems with restore not working before i installed it. click here

to remove all traces of the program use add/remove programs then delete any folders left behind in program files or wherever you installed it to.

next click start/run type rededit click ok.click my computer and then back it up by clicking file/export and save to a folder of your choosing.

next click edit/find type the name of the program or developer into the find box and click find next.

it will stop and highlight anything found,right click and delete ONLY THOSE YOU ARE SURE ARE RELATED TO THE PROGRAM IN QUESTION.

tap F3 to contine searching deleting untill it says finished searching through the registry.

restart the computer.

  hugh-265156 18:27 10 Jan 2004

sorry rededit should be "regedit"

  skeletal 21:37 10 Jan 2004

Thanks for that huggy71. I do have SP1 and yes, it does take up many GB of disc space...which is worth it, provided it all works!!

You, indirectly, gave me another idea. I tried to "use last know good registry" (or whatever) pressing F8 on restart. This caused scan disc to run, which found errors in the folder that my "unistalled" software happened to have put itself...Ho hum!!

Anyway, unfortunately, system restore still won't work, so I guess I will have to turn it off and on again.

I will try more fettling...trying not to do to much damage to the registry (and trying your idea of saving...given restore may not work!!).

If anyone else has any ideas of why SR stops working (after being OK for months) I'd be grateful.


  skeletal 23:40 10 Jan 2004

OK, more info!

I created a new restore point. Added new software (something different from VCD). Tried to restore to my new point...it worked (and correctly, the new software dissappeared). Undid the restore...it worked (new software reappeared). Tried to go back to first thing this PM...it DIDN'T work still.

So, for whatever reason, it looks like I can create new restores and use them, but I cannot go back earlier than this evening!

I'll play a bit more tomorrow...any comments still welcome of course; but it looks like I'll just have to live with it!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?