XP - problems with permissions and rstrui.exe

  Pineman100 12:03 31 Jan 2009

XP SP3. All kinds of problems suddenly, with no apparent explanation.

When I boot up, after the desktop has appeared, I get a report as follows:

Windows cannot sccess the specified device, path or file. You may not have the appropriate permissions to access them."

I tried going into System Restore, to roll back a few days, but when I try to launch it I get the report:

"You may not have the appropriate permission to access this item."

I tried looking at User Accounts, but when I tried to open it I got the same report.

When I tried to shut down, I got the report: "You do not have permission to shut down this computer."

I am the administrator, and the only user of the computer.

Any ideas what's going on, please?

  birdface 13:00 31 Jan 2009

It is a system restore problem.Maybe have a look.
click here
Or googled.click here=

  Pineman100 13:55 31 Jan 2009

I found that Microsoft article, but it didn't seem identical to my problem - no mention of "you do not have appropriate permission" problems.

Do you think they're all part of the same problem?

  Pineman100 15:21 31 Jan 2009

Thanks to the instructions in the Microsoft article, I was able to start System Restore from the command prompt. Thankfully, it successfully restored back to a date before the problem, and all is now well.

Thank you so much!

  birdface 15:44 31 Jan 2009

Glad you managed to sort it out.Good luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires