XP Pro SP2 wont recognise PCI modem

  scotbruce 16:39 08 Jan 2006
Locked

PIII 866 on Chaintech 6AjA4T with 256MB RAM.

Was running XP Pro SP1.

Upgraded it to SP2 and Conexant Churchill SoftK56 modem had uninstalled itself. Windows wouldn't recognise the modem and a manual install ended with "Window was unable to register the modem...."

Bought new Motorola SM56, thinking that the Conexant was faulty. Again, Windows wouldn't recognise the modem and a manual install ended with "Window was unable to register the modem...."

Returned it in case it was faulty and got another. Windows won't recognise the modem and a manual install ends with "Window was unable to register the modem...."

The BIOS shows IRQ3 for modem use, so it should be using COM2. AIDA32 shows an unknown PCI device. I've tried swapping to another PCI slot.

I hate modems! Help!

  woodchip 16:42 08 Jan 2006

Most PCI Modems need to have Drivers loaded from the CD for them to be sean

  dms05 16:46 08 Jan 2006

Just a thought. If you install a mini-pci card you need to install the drivers before you install the hardware otherwise you get this type of effect.

How about:
1.removing the PCI card, then
2.uninstall the drivers and reboot.
3.reinstall the drivers and reboot.
4.only now install the hardware.

It might work!

  scotbruce 16:48 08 Jan 2006

I do have the drivers CD, but there's no working Setup routine for me to install them separately. (The Setup icon leads to a pop-up with only links to the manual and registration). When Windows wouldn't recognise the modem during boot-up, that was the first thing I tried to do.

  scotbruce 16:50 08 Jan 2006

I can't install the driver, so can't uninstall and re0install them. I have removed and replaced the modem itself, but still the same. :-(

  woodchip 16:52 08 Jan 2006

Go to Device Manager\Modem\properties update driver with the CD in drive browse to inf file

  Skyver 16:54 08 Jan 2006

From past experience the SM56 modem won't work on XP,the latest edition of Windows I ever got one to work with is Win98.

  scotbruce 17:04 08 Jan 2006

Woodchip
Tried that but just got the "Window was unable to register the modem...." error message.

Skyver
I saw that in a coupla places when I was Googling, but, equally, the manual and Read Me say it will work under XP, so ....

Eeech!

Is there a clue in the fact that the Conexant Churchill uninstalled itself during the upgrade to SP2 and also then couldn't be recognised by Windows and also got the same error message?? That's a common factor.

  dms05 17:06 08 Jan 2006

<<AIDA32 shows an unknown PCI device. I've tried swapping to another PCI slot>>

Only other thought is to go to Device Manager and check the unknown device and see if you can install the drivers for it. Select the item and right click to get the options uninstall / update driver etc. Then use either your CD as the source or try searching on the Internet (if you can!).

I had to do something similar when installing a USB to RS232 Serial Port device.

Hope you sort it out!

  Skyver 17:07 08 Jan 2006

Good luck with it, anything useful here? click here

  scotbruce 17:11 08 Jan 2006

dms05
Unfortunately, although AIDA shows an unknown device in the PCI slot, there's nothing at all shown in Device Manager!

Skyver
Yeah, saw that one and others similar, but nothing too helpful - yet!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?