XP home to win98se shares

  Mikro 02:45 27 Aug 2006
Locked

I cannot get XP Home to accept the passwork when I attempt to browse the share on the Win98se machine. I can browse the share on the XP machine from the 98se machine.
I have set up an identical accounts on both machines.
I have netbeui on the 98se but not on the XP Home. Is that the problem?

TIA,

Mikro

  mgmcc 08:48 27 Aug 2006

<<< I have netbeui on the 98se but not on the XP Home. Is that the problem? >>>

No, because you normally network with TCP/IP protocol when using XP. You could if you wanted install NetBEUI protocol in XP, but it shouldn't be necessary to use an alternative protocol and TCP/IP is *essential* for the internet.

In XP, make sure you have NetBIOS over TCP/IP enabled in the settings for the network adapter that connects to the 98SE PC (presumably your "Local Area Connection"). In the Network Connections folder, right click the Local Area Connection and select Properties. Highlight "Internet Protocol (TCP/IP)" and click the Properties button. Click the Advanced button and select the WINS tab. Set the option to "Enable NetBIOS over TCP/IP".

  Mikro 13:22 27 Aug 2006

mgmcc:

Thank you for the response.
I did as you explained but xp still wont take the password. I can see the share in network neighborhood, I just cant get past the password request..

Mikro

  mgmcc 13:59 27 Aug 2006

In the Win98SE PC's Network Properties (right click "Network Neighborhood" and select Properties), try changing the Primary Network Logon from "Client for Microsoft Networks" to "Windows Logon". You could also try deleting all passwords in the PC - all the .PWL files in the Windows folder.

  Mikro 14:26 27 Aug 2006

I changed the network properties to "Windows Logon". I also deleted all *.pwl files.
I still get the password prompt when I try to browse the share...
(I really appreciate you helping me)

  Mikro 17:07 27 Aug 2006

I ran the network setup disk on the 98SE pc. Now at least I can browse a folder named "SHAREDDOCS"
I still cant browse any other shares I have made...

  mgmcc 07:49 28 Aug 2006

In the 98SE PC's Network Properties, do you have "File & Printer Sharing for Microsoft Networks" installed?

Also, have you clicked the "File & Printer Sharing" button and ticked one or both boxes as appropriate?

Do the other folders you've "shared" have the hand under their icon to show they are a network share?

Do you have any firewall software installed in the 98SE PC and has it been configured to allow access to the networked PC?

If you want to try using NetBEUI, which isn't installed by default in XP, you can either get it off the Windows CD, if you have a proper Microsoft CD, or download the NetBEUI.zip file from my website click here

  Mikro 13:56 28 Aug 2006

I tried all the things you have listed.
I have the xp firewall on for all the XP macines. The only firewall for the 98SE is the router, a Linsys WRT54G

I also tried the netbeui on XP

  mgmcc 15:31 28 Aug 2006

I'm really not sure what else to suggest. I have a Windows 98SE laptop networked to a Windows XP PC via a Linksys WRT54GS router and have no problem accessing the 98SE laptop's files. I can access them from an Apple Mac, via the same router and also without problems.

In the case of the 98SE laptop, I have "shared" the entire "C" drive, which I wouldn't do with XP, because it suits me to have access to the whole drive. It might be worth trying that to see if it gets you any further forward.

  Mikro 17:36 28 Aug 2006

Thats the first thing I did was share the entire drive "C" on the 98SE box.

Another odd thing is it(the password input) shows the "user/guest" in a grayed out box above where you input the password.

  mgmcc 19:40 28 Aug 2006

What you are seeing with the prompt for a "non-existent" password is typical of XP trying to access another PC in which there are no shared folders. Now I know that, if you have shared the root of "C" drive, this cannot be the case, but for some reason XP is unable to find a path to the shared drive. The security of 98SE is so trivial anyway that there shouldn't be a problem accessing it.

If you were having problems the other way round - using 98SE as the local PC and XP as the remote PC - I could understand it, but not the way you are doing it.

As you now have NetBEUI protocol installed in both computers, in XP try disabling TCP/IP in the network adapter that connects to the 98SE PC. Presumably this is the "Local Area Connection"; right click it, select Properties and then untick the box for "Internet Protocol (TCP/IP)". Reboot both computers and see if they communicate.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?