XP File Recovery Through Ubuntu

  Kilty 11:40 07 Feb 2011
Locked

I recently had a virus (SystemTools2011) and have decided to wipe the HDD and reinstall windows xp. I was unable to boot the machine in to Windows. I want to recover the folders and files off of the drive, so I used the Live CD in Ubuntu.

The problem I now have is that Ubuntu is only showing me one part of the drive. It is an Acer and all I can see is the ACERDATA part of the drive and not the part with all personal files and folders on it. Is there anyway of getting at that part of the drive or is it lost forever?

Thanks in advance for any help given.

  GaT7 12:35 07 Feb 2011

It looks like you'll need to 'force mount' the XP partition in order to access it & save data its data. Follow this guide to do it click here. G

  Kilty 17:15 07 Feb 2011

Thanks for the reply. I had a look at the example you sent me, but I cant get the name for the partition as its not showing in "Computer" in Ubuntu. All I can see is the ACERDATA partition and this contains no files I need.

The computer is a laptop, so Im unable to take the HDD out as I have not got a caddy with the smaller fitting for a laptop IDE. I was hoping I could do it through Ubuntu.

Thanks again for the help given and any more that maybe coming.

  GaT7 17:19 07 Feb 2011

It will be the first partition, wouldn't it? If so, use /dev/sda1 in the 3rd command in the link's guide. Worth a try I guess. G

  Kilty 17:20 07 Feb 2011

Thanks will try that and let you know.

Thanks again.

  Kilty 11:40 08 Feb 2011

Update

I have tried the mount process discribed in the link given. I have also listed the partition on the drive using command "fdisk -l". The boot partition is listed there, but when I try to mount it (using the instructions from the link), I get the message:

wrong fs type, bad option, bad superblock on /dev/sda2 /media/disk missing codepage or helper program, or other error. In some cases useful info is foun in syslog - try dmesg | tail or so

Also, the partiton sda2 is listed as FAT32 (LBA) does this make a difference?

Thanks again for all your help and any more in the future.

  MAT ALAN 11:44 08 Feb 2011

click here
might help...

  robin_x 12:38 08 Feb 2011

I don't know bout poss corruption troubles, and fix above, but certainly new Ubuntu users (including myself) have problems getting to c:\ sda partitions.

You only have to Google 'where is ubuntu c drive or similar'.

One thing I found with Puppy Linux is that it puts a nice row of icons on the desktop, above the taskbar, of all drives/partition it can see. Including c drive.
A single click and they will open or show a dialog box asking for mount or something.

May be worth spending a few minutes seeing if a Puppy Live CD helps.

click here

Of course if it is corruption it won't.

  Kilty 12:50 08 Feb 2011

Thanks for all the help. I have just done the command "sudo fsck.vfat -a -l /dev/sda2" and the results say "logic sector is size zero". After looking on a few forums, it looks like this is not a good sign. Any thoughts?

Thanks again for all help and advice.

  GaT7 13:51 08 Feb 2011

Can you connect the drive to another working Windows PC? Is it an IDE or SATA drive? Is it a laptop or a desktop drive?

robinofloxley, on account of the state of the partition, I don't think another Linux distro will help. The same error is likely to pop up. G

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?