X1100 Driver help. Please?

  Konkadonk 22:41 17 Jul 2007
Locked

My dad recently bought me a new laptop. It's got a Turion 64 X-2 TL-50, 1gb ddr2 and a Radeon Xpress 1100 Hypermemory. My problem is that when I try to run either Guild Wars or World of Warcraft, I have to do so on the lowest settings and lowest resolution. I used to play each game on my mum's laptop which has a Pentium Celeron M @ 1.6ghz , 1gb ddr and an xpress 200m and showed considerably better performance at 1280x768 with some settings high, some low etc.

Recently I tried installing XP, which to my lament faiiled. I reinstalled Vista and opened World of Warcraft and it was running silky smooth with everything on low, apart from the resolution, which was at the top, at 1440x900. As soon as I installed the catalyst drivers for my OS and graphics card, the perfromance went stale again. By the way, I have Vista 32bit. Please help!

  Stuartli 23:01 17 Jul 2007

I have an ATi Radeon 9550 graphics card, but only install the basic ATi driver.

In place of the Catalyst drivers I use the far smaller, but equally as efficient and configurable ATi Tray Tools. See:

click here

  citadel 23:08 17 Jul 2007

integrated motherboard graphics are no good for gaming. vista probably slows them down to add to the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017