WPA-PSK issue

  mathurgood 18:24 04 Aug 2006

Hi and help!

I have a wireless network as follows:

1. Desktop PC with ethernet connection (NTL Broadband cable modem), XP Home SP2
2. Belkin F5D7230uk4 wireless G router
3. Laptop with Belkin F5D8020 Pre-N network card, XP Home SP2
4. Laptop with internal wireless adaptor, XP Pro SP2

Internet access on the desktop PC is fine via ethernet. Both laptops can detect and connect to the Internet ("Excellent" and "Very good" connections throughout house) using the default router settings i.e. NO SECURITY. I have changed the default SSID and everything still works very well.

My problem is this. I have attempted several times to set up WPA-PSK security without success. When I attempt to connect to the new SSID, I get an "Acquiring network address" message but no IP address. I have waited for up to ten minutes - still no IP address on either laptop. I have tried right-clicking the network and selecting "Repair" to obtain an IP address with the same result (i.e. a long wait without success). DHCP is enabled on my router. I have also tried disabling the router's firewall - this makes no difference either. I do not use XP's firewall but I do use Norton Internet Security (I don't know whether or not this information is at all relevant). I know that both Belkin devices (wireless router and Pre-N card) support WPA. If I restore the factory settings on the router, both laptops immediately detect the network and can connect to the Internet again - but the connection is unsecured. So this seems, to me, to be a WPA-PSK issue.

Spent about (don't laugh) five hours on this today. Good job I'm a Zen master or I'd be a bit miffed by now. Any advice or suggestions would be very, very welcome.

Many thanks

Matt Thurgood

  ade.h 18:31 04 Aug 2006

1) Best not to use a Pre-n card with a 802.11g router. It usually sort of works fine, but you're not doing yourself any favours.

2) Just out of interest - all the 7230s that I've seen/used have WEP but no WPA - has yours had a firmware upgrade or something?

3) Norton - not specifically related as client firewalls cannot (in theory anyhoo) prevent encrypted signals. Not too good for networking, but never mind.

More thoughts as they develop (takes time....)

  mathurgood 18:44 04 Aug 2006

Hi again, Ade

Thanks for your response. The manual and box both assure me that my 7230 has WPA - no firmware upgrade as yet. Haven't tried WEP (128 bit) because various other forums have led me to believe that it isn't particularly secure. Is this really the case and should I try it out as an interim measure?

The Pre-N card was supplied by my employer. Is there anything that you'd recommend instead for use with a 802.11g router? I'm very new to wireless networking and there's a lot to take in.

All the best


  ade.h 18:54 04 Aug 2006

WEP is Swiss cheese in comparison. It is prety straightforward for a reasonably knowledgeable wardriver to crack with the right software (readily available).

Not really an issue while everyone had open networks, but people are wising up now, so the next weakest can be a target for the determined wardriver.

The PCMCIA card is probably alright for all we know. But if I needed an external adapter for a laptop, I would probably use a standard 802.11g USB adapter, installed without its software.

click here for my rundown on standards and hardware.

I might possibly have some concerns about the card's software (which you are probably using) as it might prefer to work with the matching Pre-n router.

Right now, I'm thinking that you should double-check your methods - is your key suitable, is the router being setup correctly, are you performing the setup over an Ethernet link? (I sure hope you are!)

  mathurgood 19:14 04 Aug 2006

The PCMCIA card works very well without any security in place, but I'll certainly look into an 802.11g USB adapter (although short on USB ports - I suppose a hub is the next investment).

The key is definitely suitable - 30 random characters, A-Z and 0-9. I'm fairly certain that the router is set up correctly - certainly works well on both laptops when the network is unsecured. I've used a Notepad file to copy/paste the SSID/PSK so there's no chance that it's a typo causing the problem.

One small problem (and PLEASE bear in mind that I'm learning as I go along, very slowly at that). When I first attempted to setup the WPA-PSK I used one of the wireless laptops to access the router ( It didn't occur to me that this could result in any problems. I assume that good old human error (i.e. me being dim) may be the explanation for my present predicament? All that seemingly happened on that occasion was that I was disconnected from the network when the SSID changed and the PSK was set and couldn't reconnect. I reset the router (via Ethernet) to its factory settings and continued. I have since used my Ethernet desktop PC to reconfigure the router.

I have a bad, bad feeling about this. Have I done something catastrophically stupid? And if so, is there any way back?



  ade.h 19:31 04 Aug 2006

Well, yes, you did do something pretty careless there! But don't worry too much, because you did absolutely the best thing for sorting it. So I don't think that's the cause of the problems, particularly if encryption works on other clients.

So, that being the case, we're looking at something on this particular laptop or this adapter. Off to prepare dinner now, but if I have a lightbulb moment, I'll be back....

  mathurgood 20:36 04 Aug 2006


Thanks again for your support. I've only just returned from dinner myself. Had a good read of your rundown on standards and hardware - wish I'd seen that before I started work.

By the way, sorry if I've given you the impression that encryption works on other clients. It doesn't. My second laptop (supplied by the school I work for) is a brand new Dell Latitude D610 (integral wireless), built by an ICT consultant who really knows his biscuits. In fact, he's kindly agreed to come over on Monday to have a look at this issue for me. Two heads (yours and his) are certainly better than one in this instance!

Let's hope something emerges. I'm out of ideas. Didn't have that many to start with.

Cheers again


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?