Won't stay shut.

  brybob 19:30 26 Sep 2007

Hi all, l am having a problem with my DVD-CD player/writer, the drawer won't stay shut so l can play or burn any CDs.
l have look in all the usual places and all tell me the player is working ok.
now at a loss as what to do next.
my pc is a HP pavilion desk top, op/system= XPhome.

  SANTOS7 19:57 26 Sep 2007

Defective drive= probably not
prank prog = probably not (there was one long time ago)

Virus/malware activity can do this, i would scan for such with whatever progs you have then try again...

  brundle 20:10 26 Sep 2007

Hit the Pause/Break button when you switch the machine on, if the drive opens its a faulty switch or something stuck in the drive stopping the tray going all the way in

  brybob 00:35 27 Sep 2007

Checked for virus/malware. none.
held the paurse/break button and it still, opens and it shuts ok but wont stay shut.

  recap 10:40 27 Sep 2007

Look for an updated driver, see if that resolves the issue.

  brybob 14:32 27 Sep 2007

Thanks recap but it says l have the best driver available.

  mrwoowoo 22:57 28 Sep 2007

Is it ejecting when you shut it,or just not clicking shut?
Try holding the eject button with a pair of tweezers and pulling it out.Sometimes the eject button sticks in due to wear or dirt.

  brybob 10:02 29 Sep 2007

when l start the PC the drawer shuts but comes straight back to open and no matter how many times l shut it, out it comes again.
l have tried pulling out the eject button with a pair of pliers, no go, still the same.its a duel dvd-cd writer /player ann has 2 drawers and 2 eject buttons one is spare and was thinking maybe l could buy a new dvd-cd players and put it in the spare dock or maybe swoping over the buttons if that it possible ? ?.

  mrwoowoo 16:34 29 Sep 2007

In my computer,right click the drive and choose properties.In the recording tab untick automatically eject cd after recording just in case the software/firmware is corrupted.
Bit of a long shot i know as a new writer is probably the answer.

  mrwoowoo 16:48 29 Sep 2007

Sometimes the data cable can cause this if it is faulty.You could try a new one or swap it with an other one.
If that doesn't work, you'll need to open the case and check your installation settings. First, you'll want to explicitly set the master/slave jumpers and not just leave it as cable select as some drives do not like this.
Another option if you can is to try it in another pc to see if it is indeed a faulty drive.
If nothing works,you can take comfort in the fact that at least they are not too expensive.

  Marko797 16:53 29 Sep 2007

It's a bit Heath Robinson I know, but have u tried getting some of this (carefully) into the button recess? Sounds like the button is stuck in the 'de-pressed' position.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?