Wireless signal Excellent / Connected BUT no net!!

  jimmybeebe 16:43 09 May 2009


I have a Packard Bell Easynote L Laptop and Sky Broadband.

When I connect my Laptop to the Sky thing with the supplied cable I can browse the internet with no problems at all.

When I unplug the cable to use wireless it does not work!

The signal strength is Excellent and says i'm connected but when I try to browse the internet I get a message saying that the page can not be displayed.... as soon as I plug cable back in it works again.

Can anyone help me?? I've tried disabling security but still no luck.

I just can't understand why it will not display the internet pages when it says its connected and the signal is excellent????

  Pineman100 17:36 09 May 2009

Did Sky give you a security key that you need to enter in order to create a secure wireless network between your computer and the "Sky thing"?

It sounds as though you need to enter that in order to establish the network.

Assuming you use Vista, click Start>Connect To. Your wireless network should be found and displayed in the window. Click on it, then click Connect. You should then be asked to enter the security key.

  jimmybeebe 19:47 09 May 2009

Windows XP
I entered the key and created a network a while back.
According to the wieless symbol at the bottom of the screen i'm connected with excellent signal strength??

  Ashrich 23:22 09 May 2009

Try deleting the wireless profile for you sky connection , then rescan for networks and enter the security code again . To delete the profile double click on the wireless icon on the task bar , on the left hand side see Manage wireless networks , highlight yours and click on Remove , then rescan .


  Ashrich 23:24 09 May 2009

Forgot to add , have you thought about temporarily disabling your firewall to see if that is blocking it ?


  jimmybeebe 09:34 10 May 2009

Still no luck!

I'm really stuck!

I just can't understand why it says i'm connected with excellent signal strength yet I can not get on the net??

  rdave13 10:25 10 May 2009

Try device manager, double click on the lan card, advanced tab and check it's not on power saving mode.

  ACOLYTE 12:39 10 May 2009

Just a thought,try updating something instead of trying to open IE,it may be a problem with IE and not the connection,if you can download updates ok then it would prove your connected.You could also open the router setup page and see if your laptop shows up in the home network wireless section.

  jimmybeebe 12:58 10 May 2009

Been on the phone to Sky for 1hr 35mins and they have no idea.... i'm waiting on a call back from someone higher up in their tech dept

  Desperate-Dan 17:53 10 May 2009

have you got wireless disabled, in your router setting? look at the bottom of your router you should see default access with an address and password, open IE or firefox type the address into your browser press enter,

  anthonystorey 18:00 10 May 2009

if you have you could have to update the firmware on you router ive just had the same problem if you are unsure how to do this give belkin a ring they will guide you through it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires