Wireless problems

  stowsettler 10:53 16 Jul 2010
Locked

Hi,
I've just got WPA security-enabled wireless broadband, and my rather aged laptop requires a wireless receiver. All that seems to work, however when I try to log on, the computer keeps asking me for a WEP code. It doesn't like the WPA code I have.
Do I need to upgrade drivers / software on the laptop, or do I have absolutely no hope of logging on with this machine?
All advice gratefully received.
Cheers
Stowsettler

  northumbria61 12:57 16 Jul 2010

In most cases, the ability to support various levels of encryption is actually a function of the wireless hardware being used. That means that there are wireless adapters that can support WEP just fine, but cannot support WPA or WPA2 no matter what you do. There's no way to just "turn it on in Windows" because it's not Windows that's the limiting factor, it's the hardware.

The easiest solution is to simply get another wireless adapter. They're not expensive, and can be had in a variety of form factors. In particular, a plug-in USB wireless adapter seems ideal for the scenario you're outlining. You need to disable the old internal adapter and you should be good to go.

This is what you should be looking for - click here

or take your pick from this list -

click here

  stowsettler 14:05 16 Jul 2010

Many thanks for the reply. I have used this wireless adaptor in a different machine and it worked fine though. Is this likely to be the only problem?

  northumbria61 21:24 16 Jul 2010

To actually answer your question, I don't have a quick way to determine across all possible wireless adapters whether they support WPA or WEP or not. My advice is to simply check the documentation for your machine or for the wireless adapter - it's almost always called out as a feature.

It's probably safe to say that all adapters still in use that you're likely to come across will support WEP, and most all modern adapters will support WPA as well.

It does point to your problem.

  northumbria61 21:28 16 Jul 2010

"Do I need to upgrade drivers" - you could go into Device Manager and right click on your Newtwork Adapter and select "Update Driver Software" - It MAY help.

  Ashrich 22:08 16 Jul 2010

Has your " aged laptop " got XP with any service packs on it ?

Ashley

  Ashrich 22:18 16 Jul 2010

There is a patch from Microsoft for Windows XP sp1 for WPA ( only , not WPA2 ) support , not needed for sp2 , for best support upgrade to sp3 . I have come across very low power laptops that cannot encode/decode WPA due to poor processor power or very low memory , but I recently worked on a 1.2ghz pentium M with 512k memory and an 802.11b wireless card that managed WPA2 very well .

Ashley

  woodchip 22:50 16 Jul 2010

Is this Laptop a Toshiba by chance? AS I had the same proble with a New I got took it back after a week as it would only connect with Wep settings

  stowsettler 08:50 19 Jul 2010

Many thanks for all your replies. A few things for me to try there. And no, it's a Dell computer - but I will check all suggestions above.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires