Wireless Printer woes

  Bennachie 13:16 10 Jul 2010
Locked

Hello, hope someone can help me.
My network comprises my desktop connected by ethernet to BT Home Hub 1 (no, don't laugh, it's rude)as an access point. Hub software 6.2.6.E. Three laptops connect wirelessly to the Hub easily using DHCP and being told to use the same address each time.
Enter new acquisition, Samsung CLP 315W wireless printer. It has a static IP outside the DHCP range of the hub and connects wirelessly to the Home Hub BUT it takes up to 10 minutes+ to actually connect. Once the handshake has been made all machines have access but if the printer is switched off, the reconnection takes forever. I have tried different channels with no change in times. However, interestingly if I change channel with the printer connected, the connection is dropped (as you would expect) but is then reconnected immediately to the new channel.
Encryption is WPA. I am thinking of going to WEP to see if that makes any difference.

All thoughts/suggestions gratefully received.
Thanks in advance.

  mgmcc 16:01 10 Jul 2010

Have you tried letting the printer get its IP address by DHCP, assuming that is an option?

>>> Encryption is WPA. I am thinking of going to WEP to see if that makes any difference.

Try (temporarily) disabling encryption altogether to see if that makes a difference. It will at least determine whether that is the cause of the problems.

  Bennachie 21:05 10 Jul 2010

Thanks, dhcp does not work. It needs a static (unfortunately) I'll try the no security route

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?