Wireless network random disconnections

  Stephanie 19:26 31 Oct 2008
Locked

I have recently started having trouble with my wireless network. I have a D-Link DSL-G624T router and a DWL-G122 USB adapter. My PC (running Windows Vista Home Premium) is the only one on the network. I keep losing my wireless network connection at random times. Both router and adapter show the lights indicating that there is a link, but Windows says there is no network and cannot find one. If I disconnect the adapter and reconnect, the connection is re-established.

I have had the setup since February this year, and it has worked perfectly until this last month.

I have checked for firmware updates but they are both up to date; ditto drivers.I moved the router even though when the network is working I always have an excellent signal. I don't really know what else to do. Any suggestions welcome.

Please bear in mind that I am clueless about wireless stuff!

  Ashrich 22:34 31 Oct 2008

Have a look at the properties of the USB ports ( root hub ) and the wireless adapter , in Device Manager , for both look at " power management " and un-tick the boxes that say "" Allow the computer to turn off this device to save power " .

See if that helps ...


Ashley

  mgmcc 22:53 31 Oct 2008

There are a couple of things which can sometimes help.

1) Go into the Router's settings by connecting to it by ethernet cable, *NOT* wirelessly, and typing its IP address into your web browser. You'll be prompted to enter its Username & Password. In the "wireless" settings, change the Channel number that it broadcasts on. The default settings are usually '6' or '11' so, if already on one of these, try the other.

2) Try giving your "Wireless Network Connection" a fixed IP address. Open the Network Connections folder ("start > Run", type NCPA.CPL and click OK), highlight the "Wireless Network Connection", right click it and select Properties. Select the entry for "Internet Protocol Version 4 (TCP/IPv4)" and click the Properties button. In the Properties sheet that opens, select "Use the following IP address" and type in"

IP address - 192.168.x.5 (where 'x' matches the third octet [number] of your Router's IP address.

Subnet Mask - 255.255.255.0

Default Gateway - 192.168.x.1 (your ROUTER'S IP address)

DNS Server - 192.168.x.1 (your ROUTER'S IP address)

Click OK back through the two open boxes. To revert to automatic addressing set *BOTH* IP and DNS back to getting their addresses automatically.

  Stephanie 08:17 01 Nov 2008

I'll have a go at both these today and report back.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?