Wireless Internet

  Chadders1989 19:48 13 Oct 2009
Locked

I am in a student house in which we have just got a BT Homehub with broadband.
All works fine, and the speeds and connections are good. However, my desktop PC just will not browse the web properly at all.
My laptop works fine in the same location, and both the laptop and the desktop show high signal and that they are sending and receiving packets. The Desktop will sign into windows live messenger so the internet is clearly accessible on it.

Can anyone advise me on what i might be doing wrong, or what could help alleviate this problem?

Thanks in advance

James

  Technotiger 19:54 13 Oct 2009

Try a different Browser - if you are using IE, try Firefox instead.

  Chadders1989 20:18 13 Oct 2009

I am using Chrome, but none of Firefox IE or Chrome work

  Technotiger 20:22 13 Oct 2009

What exactly do you mean 'will not browse the web properly' ??

  Chadders1989 20:29 13 Oct 2009

Sorry I should have been more precise.

It will almost never load any webpages.

If I attempt to go to Google it may load the page after about 5 minutes, but otherwise it will show that it is attempting to connect to a webpage before eventually timing out.

  Technotiger 20:34 13 Oct 2009

Perhaps you have your security settings too high in Internet Options.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?