Wireless Connectivity Problems

  TicTacToc 16:45 11 Feb 2006
Locked

Hi All,

I am using a Linksys WRT54G Router, a D-Link 300T DSL Modem and the belkin Desktop Wireless Adapter Card.

My laptop runs off the same wireless connection with an Intel 2200bg and it runs perfectly currently. That is why I assume it is the card. Well, actually *thinks* twice yesterday all my router and modem lights were on, my computer status' said that everything was connected with perfect connectivity but I just couldn't browse the internet. When I restarted the computer and unplugged and plugged all the cables it worked fine again, but the problem did retrun once or twice requring me to repeat the above.
Any reason why.

Now onto just the belkin desktop wireless card because at the same time my laptops wireless does work. All the router and modem lights are on and the status tab says everything is connected but when I click on a link or browse the web, nothing happens, it just sticks on the same page. If I open up a new tab or window i just get 'untitled'. In IE (that was firefox) I get a page can not be displayed page.

Restarting currently isnt helping.

Everything looks the same when it is working fine, what do you think is the problem?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?