Wireless connection keeps disconnecting ???

  Highland Guy 22:17 23 Aug 2006

Hi all, I need some serious help here guys and girls, I am trying to set up my first wireless network and it is proving to be mamoth task.

Hardware is as follows DLIK DSL-G624T modem/router
Hawking HWU8DD USB w/less adapter

The PC that is connected direct to the router via ethernet cable is working fine connecting to internet all is well.

The wireless PC just wont obtain a network address automatically just keeps sticking on acquiring a network address, unless you manually enter IP address etc. then it connects to network for about 5-10 seconds then disconnects then reconnects then disconnects you get the picture.

DHCP is running on prob machine and set to automatic.

Signal strength is good to very good so I don't think that is problem with disconnecting from network.

Enabling netbios trick not working either ??

I am running Win XP SP2 on prob PC

Any help would be gratefully received
Many thanks in advance


  FelixTCat 09:32 24 Aug 2006

Highland Guy,

Try disabling your laptop's firewall. If you can then connect, re-enable it and tell it to allow the network addresses.



  Highland Guy 19:36 24 Aug 2006

Thanks for the suggestion but have already tried this with no luck have been trying to resolve this problem for eight days now, googling most days for answers but just cannot crack this at all.

To be truthful I am at the stage of throwing the whole wireless setup in the bin and running a cat5 cable lol lol lol lol


  Jed UK 12:43 28 Aug 2006


I have been trying to get my Lenovo T41 set up for Wi-fi at public spots and at a friend's house. The wireless connection to the router seems to be OK but there are IP address problems. Like you, I have tried using automatic and fixed addresses and switching off Zone Alarm. At one point I had Google Earth working but I could not get Internet Explorer to contact the internet nor the router setup pages.

Please post a solution here if you get one. I will do so too.


  FelixTCat 13:04 28 Aug 2006


Sounds basic, I know, but have you turned the router's wireless on? Some are OFF by default. Also, check that the DHCP server is ON, wireless encryption is OFF and SSID is not hidden. Check (probably in the Firewall section of the router) that MAC address filtering is not set.

Also, if this is the dish antenna, make sure that it is pointing at the router.

Sometimes it's best to set up the laptop right beside the router; then you know the setup works.



  Highland Guy 23:15 30 Aug 2006

Have already done all of the above FTC I just cannnot see any reason why the connection disconnects, could it be possible the wireless side of the router is faulty?

Dhcp on router faulty?

I am at a total loss as to why this is happening?????


  FelixTCat 10:23 31 Aug 2006


Have you tried it with a normal wireless adapter at close range with all security disabled rather than your Hawking?



  Highland Guy 00:06 01 Sep 2006

Have tried that aswell still the same it's got to be a faulty router don't you think.


  makelle 09:06 02 Sep 2006

Belkin Wireless G Router. Since it's my friends router I don't know what happend that seems to have changed the settings since I installed the wireless network a couple of months ago. However the network consisted of only one laptop which has been used without access to the network for a while on holiday...

Now that's history. When I first started the computer no connection whatsoever was possible and no networks were found. So I started to create a new home network just as I did when I first installed it. That didn't do the trick.

I then reset the router to its factory settings using a wired connection. I also reinstalled(with CD) the router and discovered that some of the network parameters where not changed but were retained so I first thought I could use them without changing or modifying them. This actually made it possible to detect other networks in the neighbourhood but not the one I was installing.

I thought this was a bit funny since my router was clearly the one which should have had the strongest signal so I kept trying to seek for networks that I could connect to. Suddenly there appeared a new unprotected network with a very high signal strength that wasn't there before. I tried to connect to this new network and lo and behold the name changed before my eyes to the one I was configuering. So I was quite sure I had a connection to my router at hand but this is the point where our mutual problem that we are discussing now came in to play.

The laptop was clearly trying to connect to the router but no persistent connection could be negotiated. I then went back to configuration with a wired connection(of course) and started changing all kind of parameters(I was quite frustrated I must admit) keeping some and changing others in a random fashion hoping something would turn out to make me struck the holy grail...and at last it worked. I had changed everything but the master password but including the WPA-PSK key(Pre-Shared Key).

So what you should do is probably a complete reinstall from factory settings, change all parameters and keep everything else crossed including your fingers (I was also cross-eyed).


  Highland Guy 22:39 28 Sep 2006

Thank's to everyone for their input into my problem.

The wireless network is now working fine, seems D-Link routers have a problem with the WPA encryption as it was designed to use a seperate key server but some bugs in the home version.

I simply reset everything to factory settings binned the WPA and used WEP instead and bingo it worked.

I had tried this before with no luck the only thing I did different this time was to save router settings after changing back to factory settings then started configuring router and saving after every change.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?