Wireless connection issue with new Vista laptop

  shanklyn 17:47 07 Jan 2008

Hi got myself a new samsung r40 laptop today but keep disconnecting from my wireless router, I have 2 laptops in the house 1 is an Acer, identical to my previous laptop and it never had any connection issues in the past.

The strange thing is that when I connect the signal strength is full (as it always was with my acer) but then in a short time it disconnects. It shows as limted access in the network sharing centre ? Network discovory is showing as custom ? is this correct.

The property I am in is quite small and as i said with the Acers I have never had any issues.

the laptop is running McAfee if this is of any help.

  johnnyrocker 17:48 07 Jan 2008

try vista forum?


  paul€ 18:04 07 Jan 2008

Have you got the Vista firewall turned off. The router should have it's own firewall running and does your McAfee also run a firewall?

  shanklyn 21:02 07 Jan 2008

I have uninstalled McAfee and turned off windows firewall, it stays connected for a few minutes and then knocks off. It works fine via ethernet.

The signal is also up and down when my other laptop is always excellent.

cheers for the help so far.

  paul€ 08:18 08 Jan 2008

Try changing the channel on the router. Most have a range of 1 to 12. Mine was on channel 11 and kept dropping, so I changed it to 6 and it's been fine ever since.

PS I also had to drop the Vista firewall till I had a good strong, long connection. Then I re-enabled it, along with the hardware firewall of the router.

  paul€ 08:20 08 Jan 2008


I never, ever dropped the hardware firewall of the router. It looks as if I dropped both with the above comment, but I just dropped the Vista one.:)

  Graham. 10:18 08 Jan 2008

Are the other laptops XP? The router may need Vista drivers.

  ricvic 10:23 08 Jan 2008

I had a similar problem with my vista laptop. I tried the channel changing & other tips. I tried an external wireless adaptor, which worked much better than the internal. Even after going back to the supplier (novatech) for a new internal wireless card it was not good. But that all changed with the latest download of drivers. Conclusion (for me, anyway) is that the drivers were buggy. Have you tried upgrading the drivers?

  FreeCell 10:46 08 Jan 2008

The router won't have "Vista drivers" but you may find an updated Vista driver for the wireless network card. Check Acer support site for you model number.

The router however may require an update to the firmware for Vista. You don't say what make you are using.(Some Speedtouch routers have needed this to get Vista connected PCs to work.)

  shanklyn 23:31 08 Jan 2008

Thhanx for the help, here is what I think did the trick for me.

1. Go into the device manager and look at the properties for your wireless card, now under power management there is an option to turn the device off to save power, make sure that is unchecked and your problem should be fixed!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

How modern book design was influenced by illustrated manuscripts

Best Black Friday Apple Deals 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)