Wireless connected but no access to the internet

  Whistleworm 11:00 04 Sep 2006
Locked

I have two PCs using the same DLink wireless router.One has only a wireless card and connects fine. The other has an ethernet card and a wireless card. This one will only access the internet via the ethernet connection. Wireless is connected and communicates with the router but I cannot connect to web sites via internet explorer if I remove the ethernet cable. I want to move this PC to another room so need the wireless connection to work.I've tried turning off the Internet security, have compared all the settings with the PC that does work but still canot get the access to the internet.
Any ideas?

  xania 11:33 04 Sep 2006

Try deleting the ethernet card drivers and then removing the ethernet card - could be causing as conflict.

  mikesuther 12:23 04 Sep 2006

from past experience, when i was able to connect to the router through a wireless connection it meant that i had not set the encryption password. so i was able to share files with the other pc on the network but could not surf the net or send or receive email. you probably have checked but just make sure that you have typed in the password that is normally reccomended. As for deleteing the ethernet connection i have to say unless there is a specific conflict i would be wary of deleting the driver. the reason being my laptop has an ethernet port and wireless connection, the reason being that if i am in a location that has one or the other options available then i have the option of using a specific connection type. also if your wireless card is made by intel there have been some updated software which you can download from the intel site. i hope this helps

  FelixTCat 14:16 04 Sep 2006

Whistleworm,

Connecting via ethernet and then simply removing the ethernet cable will not automatically make your pc connect via wireless. All it will do is notice that the ethernet connection no longer exists and refuse to connect.

If you want to force Windows to change connector, disconnect the ethernet cable, open a cmd window (Start - Run, type cmd [Enter]) and type ipconfg /release [Enter], then ipconfig /renew [Enter].

That forces Windows to look for a new connection to the router and will find the wireless connection.

When you want to go back to an ethernet connection, disable the wireless connection, connect the ethernet cable and repeat the ipconfig process.

You cannot connect to the router by ethernet and wireless at the same time.

Regards,

Felix

  Whistleworm 19:57 04 Sep 2006

Thanks folks for the suggestions. The ethernet card is part of the motherboard and can't be removed.Encryption checked and ok. Tried FelixTCat suggestion but message 'no operation can be performed on Local Area Connection while it has its media disconnected'. I connected the ethernet cable and typed ipconfig/release,then disconnected it and typed ipconfig/renew but it made no difference.
The icon on the taskbar shows that there is a wireless connection but still IE comes up with the message 'cannot display the webpage'.
Any other suggestions?

  skidzy 20:04 04 Sep 2006

If not the WEP key encryption..i had this problem on saturday.

Sounds like you need to configure the firewall to allow access assigning the ip address.

I noticed you mentioned,you have turned off internet security...did this include the firewall.

  Whistleworm 09:20 05 Sep 2006

thanks Skidzy I've checked and windows firewall is turned off. I've tried entering the route id 192.168.0.1 and it successfully communicates with the router. I've done the test provided by the DLink utility and everything passes. However when I try to access a web page it fails. If I then plug in the ethernet cable I can immediately access web pages. Seems strange to me. Why will it not access the web through the wireless communication?

  skidzy 16:07 05 Sep 2006

Just a thought Whistle,the wireless card is enabled isnt it ?

I also have a d-link and every so often it goes down,so i start by clearing out all the old settings run regscrubxp,reboot and start again,tedious i know.

If its working via ethernet and not by your wireless card,this would point me to the Encryption key (WEP).

Something you could try is using windows to configure the router and a flash drive to carry over the settings instead of manually setting it up.
Control Panel/Network and internet connections/setup a wireless network..follow the prompts.

  The Old Mod 16:09 05 Sep 2006

Hi, I had this problem, and what I did to cure it was this, I networked the two PCs. I run the network wizard on my main PC, followed the instructions, it asks you to put in a removable media such as a floppy or flash drive, I run that on my laptop and bingo, could access the internet. Hope this helps, good luck.

  PBE 17:05 05 Sep 2006

Whistleworm - did you get resolution on this. It sounds like a similar problem I've got trying to connect to a new Netgear router. I've just posted the details.

  skidzy 17:10 05 Sep 2006

After tinkering with my router and the software that came with it,ive found it easier to follow my post earlier and that of The Old Mod...basically ignore the software that comes with the router,and use windows and a flash drive.

Quickest and easiest for me.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?