Wireless adaptor drops internet connection

  mcmullen1990 20:25 13 Oct 2010
Locked

My internet connection on my P keeps dropping, my laptop and other laptops work well however. I think it may be a problem with the wireless adaptor as unplugging and re plugging it tends to restore connection.

I don't believe its because of the computers location because my laptop works fine there. I've reinstalled the wireless adaptors drivers, removed the network and rejoined and unchecked power save mode for the adaptor to no effect.

The adaptor is an Edimax Ew-7711UTn
The router is a Netgear VMDG280
I'm running windows vista

Thanks for any help anyone can give.

  mgmcc 08:38 14 Oct 2010

Try changing the Channel number in the router's wireless settings in case interference is causing a problem with that particular network adapter.

  mcmullen1990 16:50 14 Oct 2010

Sorry to be an idiot but how would I do that?

  mgmcc 20:34 14 Oct 2010

While connected to your router by ethernet cable, *NOT* wirelessly, type your router's IP address (probably 192.168.0.1 or 192.168.1.1) into your web browser. This will open its configuration pages. You will probably be prompted for a Username/Password and the default settings for these should be on a label on the underside of the router.

Once into the configuration pages, there will be an option within the wireless settings to set the Channel number. Most routers use either "6" or "11" as the default channel so try one of these or, if already using one of them, try the other.

  mcmullen1990 13:20 16 Oct 2010

I've tried this and can't seem to find a channel which is any better. I've realise that the connection isn't actually dropping most of the time it's just going very very slow. Dropping from its usual 135 mbs to 13.5 mbs. When I pull out my wireless adaptor and plug it back in I get a temporary return to fast speed then it drops off again.

  mgmcc 17:13 16 Oct 2010

I cannot offer any logical explanation for that behaviour, although I do have one of these Edimax adapters and it didn't perform well with Windows 7 (haven't tried it in Vista). It is a 150Mbps 802.11n adapter and would only connect at 54Mbps in my Win 7. However, it does connect at its full 150Mbps speed in my XP Laptop.

If you're using it with a desktop PC, does that computer actually need a "wireless" connection or could it be connected to the router by ethernet cable, which will always be more reliable.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?