wireless adapter not connecting to network

  Tstarter 10:14 07 Nov 2006

I have a Dlink wireless router DSL-G624T and adapter DWL-G122. Router is all set up and working fine.
Adapter is for a Win98 computer. Initially couldn't get it to work so disabled the security and got it to work.
Enabled security - WEP 128 - and got it to work absolutely fine. Thought I'd cracked it, but when I next turned the computer on, it wasn't working.
In the "view available networks" screen, it shows the network ok (signal strength 60-70%); but it just won't connect to it.
I've tried the DLink help from click here= and have tried everything they suggest.

I'm wondering if it might be somehow related to the computer start up. The lights on the adapter will flash ok when the computer is first switched on, but go off when it is fully booted up. It seems to be everytime I've turned off then turned on again that the problem occurs - because i HAVE got it to work several times.

I suspected the firewall (zone alarm) might have been the problem as when I uninstalled it the adapter connected fine. However next time I turned on it was back to not working!!!

Any thoughts....??

  Strawballs 10:19 07 Nov 2006

90% of network connection problems seem to be down to firewalls, I do not use zone alarm (I use McAfee) so I have no experience of it but I am sure that is what your problem is and you have to find out how to configure it to allow your network traffic

  Tstarter 10:22 07 Nov 2006

but if I have actually totally uninstalled the firewall, can it still be causing a problem?

(I do still have zonealarm running on the other computer that is wired to the modem/router)

  Strawballs 10:37 07 Nov 2006

Does the adapters software run at start up or could it be that you have to click on it's icon to get it running, it has been a few years since I used 98 and never for wireless, only had a hub in those days.

  Tstarter 10:51 07 Nov 2006

yes, icon comes up in bottom right, but immediately shows the "non-connected" version.

  mgmcc 11:26 07 Nov 2006

Try deleting any existing "profile" in your wireless settings, then go through the procedure to "Connect" again. You should be prompted to enter the WEP code (I assume you are using 26 hexadecimal characters) and once connected, a new profile should be created. Alternatively, you may be able to set up the profile manually and then "Connect" using that profile.

  Tstarter 11:53 07 Nov 2006

mgmcc - have tried that, even renamed the network and started again.
Might try again thou!!

  Tstarter 09:39 08 Nov 2006

ok - still not working.
I looked at winipcfg and noticed that the IP address listed (something like 168. something) bore no relation to the IP address of the router ( Stupidly I forgot to write down the actual numbers!!
Could this be causing the problem?
If so, how do I fix it?

  mgmcc 11:55 08 Nov 2006

If winipcfg shows a "169.254" address, the network adapter has been unable to get an address from the router by DHCP and Windows has defaulted to allocating an APIPA (Automatic Private IP Addressing) address in the 169.254.x.x range. This won't let you get online.

Try disabling WEP again and see if you can then connect to the router.

  Tstarter 13:34 08 Nov 2006

thanks mgmcc
I have disabled WEP though, and it is still showing that.
Any thoughts on how I can change it?

  mgmcc 14:30 08 Nov 2006

You must get the Wireless Adapter to "Connect" (as in "log in") to the Wireless Network. Only then will it communicate with the router, get its IP address and let you connect to the internet.

Are you getting any error messages when it fails to connect, or any other indication of what the problem is? Presumably the same computer is getting online with the router using a "wired" ethernet connection?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?