Winows 2000 Pro - Slow shutdown

  Diemmess 09:55 18 Oct 2006
Locked

In the last few days with no other snags or signs, the Shut_Down time has increased from a few seconds to 66 seconds.

This happens every time, whether rebooting or closing down altogether.

The Start > Shutdown routine seems to run quickly at first and within a second or so shows "Saving your settings"

It doesn't appear to freeze, because the wee blue line undulates gently as normal, and then a full minute passes before the procedure finally clears to a normal plain background and goes off.

Nothing abnormal in msconfig or has changed since the last CCleaner and other checks.

Is there a simple registry correction or what?

  Gongoozler 11:11 18 Oct 2006

It's not unusual for Windows XP shutdown times to vary greatly, but see if this helps click here

  Jackcoms 11:59 18 Oct 2006

"It's not unusual for Windows XP shutdown times to vary greatly"

Agreed.

But Diemmess is taking about "Winows" 2000.

  Jackcoms 12:01 18 Oct 2006

This works for XP. Not sure whether it also applies to 2000.

1- Start/Run and type Regedit
2- Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CURRENT CONTROL SET/CONTROL
3- Click on “Control”
4- Select “Wait to kill service timeout”
5- Right click and select “Modify”
6- Set to a lower value than 2000
7- A setting of 200 will be sufficient

Normal setting (in XP) is 2000 but can safely be reduced to 200 for a quick shutdown. Sometimes in PCs, including my own, an extra nought is added on to make it 20000. Not sure why this happens but when it does it leads to a very long shutdown time.

  Diodorus Siculus 12:02 18 Oct 2006

Microsoft Windows 2000 - this is one cause of a slow shutdown on 2k click here

  Diemmess 12:52 18 Oct 2006

Thanks for such an interesting array of ideas.

No time to explore these in detail so far, I have to go out to help a son with house moving.

BUT
The registry keys seem to display many slight but significant differences though I did find my way to ClearPageAtShutdown and find that is already set to 0

The links suggesting uninstalling hot fixes give a list from KB 908531 to 925486 but no sign of anything as early as 329170.
That link does mention "pre SP4"
SP4 has always been on my basic 2000 installation
Diodorus Siculus and the Application Log

  Diemmess 12:58 18 Oct 2006

The application log shows the errors
Event Type: Error
Event Source: Server
Event Category: None
Event ID: 2504
Date: 18/10/2006
Time: 09:40:54
User: N/A
Computer: HOME
Description:
The server could not bind to the transport \Device\NetBT_Tcpip_{7A681456-B306-4A1B-BC13-4AE72C36EC04}.
Data:
0000: aa 05 00 00 ª...


Hope that makes sense to someone?
All seems to have started since last Sunday
Will come back later.

  Diemmess 16:47 19 Oct 2006

Discussion is SO useful because the fall-out often points to a solution "another way."

Thanks to all who contributed my diminishing gray cells noted

1. The error log showed no errors before 15/10/06

2. Three (last) Windows Hotfix was installed on that day

3. The same (to me incomprehensible) error occurred at every shutdown.

4. I noted the Hotfix numbers 923191, 923414, and 924191

5. In add/remove I deleted them one at a time and rebooted each time.

6. Rebooting after deleting the second Hotfix the computer shut down (for reboot) in under 6 seconds.

Job done, many more thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone