Windows XP Pro.SP2 Error Logs

  Tony W. 14:36 25 Apr 2008
Locked

Following the successful outcome of my previous post I wonder if anybody has the answer to the following;I have Windows XP Pro.SP2 in my computers error log about 12 times a day I keep getting this error message-DCOM 10020 The machines wide default launch and activation descriptor is invalid it contains entries with permissions that are invalid therefore the requested was not performed.This secutity permission can be corrected using the components service administration tool.
I would be grateful if anybody could tell me how to get to this tool and also exactly what permissions I have to put into it.Many thanks.Tony W.

  johndrew 19:52 25 Apr 2008

click here

There may be something that points you in the right direction.

  Tony W. 12:15 30 Apr 2008

Dear Johndrew

Thank you for your help I am busy going through the many posts as a result of the link you posted.Some suggest that unless the errors interfere with the computers performence they can safely be ignored?.
If anybody has Windows XP Pro (and can find the time) could they possibly through the component administration tool,look at the Com Security section and let me know what the settings should be for the Access and launch permissions. For the following-Adminstrator,Interactive,Everyone,Network,system.

Or as the only user of the computer can I safely remove some of the above mentioned.Tony W.

  johndrew 12:46 30 Apr 2008

I have XP Pro and if you can give me the route to Com Security I will have a look. As you know there is a lot of information there and it takes some time to wade through without a quick reference.

  iscanut 12:58 30 Apr 2008

This article might be of interest but may not be relevant to your problem.
click here

  Tony W. 13:27 30 Apr 2008

Dear Johndrew

Thanks I would very much appreciate it if could check your settings.This is how I get to the relevant section.1 Start-2 Control Panel-3 Administrative tools-4 component services-5 Expand component services-6 Expand computers-7 right click my computer-8 properties-9 com security-10 Access permissions-11 Edit default this will show a list of users and below will be their permissions.12 Then back to com security-13 Launch and activation permissions edit default -14 list of users and below as before permissions given.
There may well be a quicker and easier way of getting there but I copied these instructions from one of the Google posts you put me onto.Once again many thanks for taking the time and trouble
to do this.Best wishes Tony.W.

  johndrew 13:42 30 Apr 2008

Access Permissions: Self: Allow System: Allow
Launch Permissions: Administrators: Allow Interactive: Allow System: Allow

`Allow` = all boxes checked in both cases.

Hope this solves it.

  Tony W. 09:22 01 May 2008

Johndrew.

Last night I changed my Access and Launch permissions to correspond with those you gave me. This morning I logged on and checked the error log and there were none!So once again thank you for taking the trouble to provide me with the information.Tony.W.

  johndrew 09:25 01 May 2008

A pleasure to help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone