Windows XP Network connection times out

  tallboy 22:16 02 Feb 2007

I recently fitted a new HDD to my 1.4GHz Athlon Mesh computer (built in 2001) and then 'upgraded' the OS from Windows 2000 to XP. For my broadband access I connect to a SpeedTouch 4-way router via a D-Link USB to Ethernet 10/100 Network Adapter.

For the first couple of months (since the upgrade) everything has been working fine. However, now my network connection times out and disconnects after 2 hours 4 minutes - without fail! The only way I have found to get the connection back again is by re-booting the PC - which works every time, but I should have to do it!

When it fails I get the following MS networking message:

Limited or No connectivity: 'You might be able to access the Internet or some network resources. This problem occurred because the network did not assign a network address to the computer.'

When I click on 'repair' Windows does not renew my IP address - hence I have to reboot to get back online.

The following items are clicked in the Networking set-up window:

Client for Microsoft Networks
File & Printer sharing for Microsoft Networks
QoS Packet Scheduler
Internet Protocol (TCP/IP)

If you know what might have got changed to create a 'time out' routine and how to fix it so that I don't get disconnected, please respond asap!

Many thanks


  howard64 15:21 03 Feb 2007

in your router there should be a setting to remain on or switch off after a given time.

  tallboy 19:34 03 Feb 2007

I don't think the router is the source of the problem, as the other PC that is connected to it continues to operate OK after the Mesh PC times out.

Any other suggestions?

  Ashrich 20:52 03 Feb 2007

Check for the USB port shutting down to conserve power , easy to check in Device Manager , it's the root hubs you need to look at . I would also suggest you buy a cheap 10/100 PCI network card , much easier ...


  tallboy 16:53 04 Feb 2007

Many thanks for the tip Ashley. I looked at the root hubs and sure enough, the conserve power box was ticked. I've now cleared it, so I'll see in a couple of hours if the connection stays live.

I've recently put a new 4-port USB 2.0 hub in the PC and the rooter is connected to one of these ports. The original motherboard USB 1.0 ports don't appear to have any power management facility, which would explain why I didn't have the problem previously when the router was connected to one of these.

I agree a 10/100 PCI network card would be a better solution. However, when I first switched to broadband and purchased my router (in 2003) I tried a couple of different network cards and the PC wouldn't recognise either of them. (Unfortunately when I purchased this Mesh PC in 2001, I elected not to have a network port included in the configuration - a bad mistake!) I even went to the length of having our local PC repair shop take a look at it and they could'nt get a network card working in it either. (At that time I was using Windows 2000 Professional. I now use Windows XP Home edition. I haven't tried a network card since changing to XP) If you have any suggestions as to why it won't accept a network card, I'd be pleased to hear from you - although now I'm not sure if there is a free slot to put one in. (I also have a video capture card installed, which because of its size, occupies the space of two cards.)



  Ashrich 22:29 04 Feb 2007

It is quite often just a case of finding the correct PCI slot for so many things , making sure there are no IRQ conflicts , XP stopped that happening to a certain extent but instead of throwing up an error the thing just wouldn't work leaving you to try yet another slot , or worse still moving everything using a PCI slot around until they all work properly...


  tallboy 11:57 06 Feb 2007

Alas, after removing the ticks from the power management boxes for all of the root hubs, the network still disconnects after 2 hours of 'on' time.

I also tried plugging the D-Link USB to Ethernet converter back into one of the original USB 1.0 ports - but the same thing happens.

Any more ideas as to what is causing this connection to time-out would be much appreciated as it's most annoying - especially if you are in the middle of a download!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?