Windows VISTA backup service missing

  NRB 20:32 10 Apr 2009

Can anyone help with this problem?

A friend has recently purchased a Sony lap top with Windows VISTA Home premium. About a month ago it appeared to lose the BACK UP and RESTORE facilities to write and recover files from disc ( no visible buttons) and closer investigation showed that the System Restore facility also fails and gives an error message which includes ‘specified service does not exist (0x80070424. Please check system configuration.’

A closer look reveals that WINDOWS BACKUP is missing from the list of services.

Some time ago Registry Patrol was loaded and later removed as it was thought to be malware. A check with RegCure suggests about 250 empty registry entries.

Consulting various Microsoft sites it seems that 0x80070424 is usually associated with loss of the BITS system and failure to get updates downloaded. Using the Microsoft site BITS seems all present and correct but it seems this problem may be a near relative.

Does anybody know how to restore the Windows Backup System or does it seem that a reload of VISTA is necessary?

Grateful thanks for any suggestions.

  Taff™ 09:36 11 Apr 2009

Have you tried a System File Check? Probably won`t get the Backup service but you`ll have all other essential OS files returned.

  NRB 17:22 11 Apr 2009


THanks for the comment. No I haven't or rather I have and couldn't make it work. There is something I don't understand about SFC. However I think I have solved the problem by booting in safe mode whence System Restore appeared to work properly and allowed me to get back to an early March OS. After a few trials and tribulations I seem to have managed to get all the updates and everything seems to work - fingers crossed.

Thanks again


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?