Windows Protection Error

  Kasio 09:16 11 Nov 2005

My computer has been fine until a few days ago. When I boot up it says:

Sector not found reading drive C:
Abort, Retry, Ignore, Fail?

So I press 'i' for Ignore and it continues booting. Then another message appears:

While initializing device vdk:
Windows protection error. You need to restart your computer.
Press any key to continue...

I press any key and it shuts down. It keeps on doing this. When I try safe mode it does this:

While initializing device vdk:
Windows prot

Sometimes it even hangs. When this happens I just turn it off.

Plz help as I need my files for school.

Thanx in advance...


500MHZ P3

P.S. I've tried another keyboard

  Chegs ® 09:33 11 Nov 2005

It wont help your PC boot with 1GB RAM in 98se.The max you should use is 512Mbs/768Mbs(depending on where you read it)The VxD errors are often easily rectified by Scanreg /restore.

  Gongoozler 09:37 11 Nov 2005

Hi Kasio. It sounds like your hard drive has developed a bad sector. This is quite common with older drives, and if it happens often then you need to think about getting a new drive.

You may be able to recover from this without losing any data.

Boot up to a command prompt. When you switch on the computer, hold down the Ctrl key until you are given the various options including "Safe Mode" and "Command prompt only"

Select "Command prompt only", and in the Command Prompt box, type Scandisk /surface. That should find the defective sector.

  Skyver 09:39 11 Nov 2005

It sounds as though you need to do a disk check too, press F8 a few times while booting, select Command Prompt Only when you get the list of options, type `scandisk c:` , or `scandisk c: /surface` for a thorough check.
`Scanreg /restore` after that as Chegs suggested.

The >512mb issue can be mitigated with Cacheman, the 9x version is free as far as I know click here

  Gongoozler 09:42 11 Nov 2005

It's quite possible that you will need to define the drive to be scanned (I'm getting a bit rusty on Windows 98. Try Scandisk C: /surface.

  Kasio 09:48 12 Nov 2005

I've tried ScanDisk, it says it isnt a LBA drive, when it actually is

also scanreg freezes


  Skyver 09:50 12 Nov 2005

Take a look in the BIOS for the drive manufacturer and download some diagnostic software from the relevant site - your HD needs checking.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?