Windows Installer Service could not be accessed

  tallboy 10:17 20 Jul 2009

Earlier this week I had to perform an XP Repair installation to fix a corrupt MBR.

My Mesh PC is now working again and so far the programs I used seem to be present and working.

However, when I tried to update Windows Media Player to Version 11 I ended up with a corrup registry and the 'Blue Screen of Death (for which Fruit Bat kindly gave me the fix-it instructions).

I have just tried to install a new Logitech webcam and got the message 'A critical error occured whilst installing MS Windows Installer 3.1. Error: (1603)

I then tried to remove a maintenance program I installed a couple of weeks ago (thinking this might be causing the problem) and got the message 'The Windows Installer Service could not be accessed. This can occur if Windows Installer Service is not correctly installed'.

How do I re-install the Windows Installer Service without going through the 'pain' of a Repair install again? (And this didn't install IE8 correctly!)

All suggestions welcome.

  VoG II 10:22 20 Jul 2009

Try this click here

  tallboy 12:34 20 Jul 2009

Many thanks for the fast response VoG. Actually, after I posted my message it occured to me that there should be something on the MS Knowledgebase and I ended up at the same article. However, all is not well!

Firstly I tried Method 1 (Re-register Windows Installer). This had limited success. It enabled me to remove the program that I thought might be causing a problem.

I then tried installing the new Logitech webcam s/w again. This came up with the error message 'Installing MS Windows Installer 3.1 failed. Error 1603.'

Following this I tried Method 2 from the MS Knowledgebase article. This came up with the message 'Setup has detected that the Service Pack version (which is SP3) of this system is newer that the update you are applying. There is no need to install this update.'

So it seems that I am caught between a rock and a hard place. The Logitech install disk is trying to install the latest version of Windows Installer (which is newer than the one you can download from the MS KB) but is being twarted by some files in the System32 directory and / or in the Registry. Is there a way I can remove the faulty Windows Installer (without screwing up anything else) so that the Logitech disk can install the latest version? (3.1)

  VoG II 17:04 20 Jul 2009

I found this - may be worth a try click here

  tallboy 17:38 20 Jul 2009

Thanks for the link VoG. I see from the first part of Triple X's instructions it follows the Microsoft KB article. The MS .exe file is the same one (from KB article KB893803) that I tried. This article was published in 2005 - before SP3 was issued - hence when I tried it, I got the message that I didn't need to install it. (MS install program obviously thought I was trying to do an 'upgrade' using an old program.)

Since I am trying to install a brand new Logitech webcam and it is Logitech's install program that throw up the error, I have posted a help ticket with their technical guys. I'm hoping they will come back with a fix! (Such as completely uninstall the current Windows installer and let their program install a newer version.)

I think I will await their reply before trying anything else. If I get a useful fix, I'll post it here for the benefit of other readers.

  tallboy 10:12 23 Jul 2009

I have now fixed this problem, so for any PC Advisor readers with the same issues (and they seem quite common!) here are the links you need.

1.Firstly get the latest version (4.5) of Windows Installer, in readiness for installing it. Go to click here read through the article and get the version you need from the appropriate link.

2.See Method 2 of the 2005 MS Knowledgebase article click here and follow this process to install the latest version of Windows Installer obtained via 1 above. (Don't follow the link at instruction 12 - this will not take you to a point where you can download the latest version)

If you have any partly-installed programs that use Windows Installer, the Windows Cleanup Utility should get rid of the installation log details. See click here

I hope this helps. My new Logitech camera is now working fine - although I'm still awaiting a second response from Logitech. (Their first one didn't fix the problem)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?