Windows incorrectly identifying a device...

  welshlion 12:10 10 Sep 2006

Connected via a USB port...
It's a printer but the Windows "new hardware found" window describes it as a "generic usb hub".
The instructions that came with the printer says that you should click cancel on any add new harware windows that pop up and I've done this and then when I run the istallationd disc the program seems unable to see the printer as it keeps asking to check the connections and make sure the printer is turned on.

Things I have tried so far: connecting the printer to another computer to see if the fault lies in the printer itself, but no.. that computer identified it ok.
Opening up the device manager and checking that the USB ports are working correctly, Windows claimed they were but I clicked to update the drivers anyway and got told my drivers are all up to date.
Visited the Microsoft Knowledge Base and found a suggestion to uninstall all the USB ports and then restart the computer and reinstall them.

None of those had the desired affect and so I'm now looking for another thing to try to resolve the USB problem or a possible work around.

Thanks in advance.

  The Kestrel 15:44 10 Sep 2006

Are you connecting your printer to the PC through a USB hub with no separate power source? If so this may be the problem. Try connecting the printer directly to a USB port on the PC and see if that cures the problem.

  welshlion 18:56 10 Sep 2006

I'm connecting via a USB port on the PC, I have 4 vacant ports and have tried them all to no avail.
I've also attempted to connected using an unpowered 4 port hub.

  welshlion 14:16 11 Sep 2006

By a process of trial and error I managed to work around this problem and my all-in-one printer is now installed and working correctly.
In case anyone else has a similar problem here is what I did:

First I visited the printer manufacturer's website and downloaded the appropriate driver program,which I saved to my desktop.

I then turned on the printer and connected it to my computer, when the new hardware found window poped up I clicked "cancel". I then opened up the control panel and clicked on add new hardware, and then used the install disc where prompted..this resulted in the printer being installed and made operational but it still wasn't installed correctly and it was at this point I ran the program I had downloaded, when a small window popped up saying parts of the prgram was already installed and asking if I wanted to overwrite them I clicked on "yes to all" and away it went and installed all the missing bits.

  €dstowe 14:24 11 Sep 2006

You ought to reveal the make and model of printer if you want your advice to be useful as they vary in the installation procedures. For example most Epson printers MUST NEVER be connected before the software is installed.

  welshlion 14:34 11 Sep 2006

Why? The problem was with the computer and not with the printer and the fact that no one appears to have come across this particular problem before leads me to think it will only occur with printers or other devices that you have to connect to the computer prior to running the installation program.
But if you really are interested it was a Lexmark X1270 that I installed.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Interview: Camille Walala on her giant 3D installation inspired by childhood funfair visits

Best iPad buying guide 2017

Où regarder le British Open 2017 ?