Windows File Protection - don't understand warning

  NickyK 11:28 16 Dec 2004

Can anyone tell me what to do about this warning which appeared:

"Files that are required for Windows to run properly have been replaced by unrecognized versions. To maintain system stability, WIndows must restore the original versions of these files.

"The network location from which the files should be copied (C:\WINDOWS\SERVICEPACK FILES\i386/ is not available.

"Contact your system advim or insert SP2 Source Files now"

"Possible reasons: path unavalable due to netwoprk probs; server path unavailable/renamed;
no permissions on server status"

I a single XP2/IE6 with SP2 installed yonks ago and am not a network.

Any advice garetefully received.


PS I haven't actually been anywhere or altered anything.

  rawprawn 11:38 16 Dec 2004

Try running a system file check, go to Start/Run/type sfc /scannow (Note the space between sfc and / ) You will need your XP Disc.

  NickyK 11:54 16 Dec 2004

Okay. I'll try that. Ta. N

  NickyK 12:46 16 Dec 2004

I ran the system file check which, once it had finished, simply switched off without displaying any results/information. Is that an okay?

  €dstowe 12:57 16 Dec 2004

Can you do a System Restore to before this happened?

Do you have a backup you could restore from?

  NickyK 13:12 16 Dec 2004

Not as far as I know

  rawprawn 14:58 16 Dec 2004

Are you still having the problem, if not sfc has fixed it. Did it as for your XP CD ?

  NickyK 16:56 16 Dec 2004

Sorry not to have replied sooner, rasprawn - I had to go out. The sfc didn't ask for my XP CD. It ran its course then simply switched off, so I am not sure exactly where I stand. I'll leave this topic open for a bit longer, since I am not quite ready to resolve it jusr yet.

  NickyK 23:15 16 Dec 2004

I never totally solved this problem, but I'll see how things go for the next few days.

  NickyK 10:22 17 Dec 2004

Update: Coincidentally to the above problem, my Media Player 10 started claiming that it was incompletely installed (having been fine for ages) - each time I tried to reinstall it, the same warning came up ("not completely installed"). I had to roll back to MP9.

I decided to do what the initial warning (re: missing/replaced source files) advised and reinstall SP2 source files. Annoyingly, this meant reinstalling SP2 in total since I couldn't find a way to do a selective installation. Anyway, once this was done I was able to reinstall Media Player 10 successfully.

I still don't know how the problem I posted at the start came about, but I would guess it happened because of a newly installed program that might have caused some kind of conflict.

  JohnC123 12:46 12 Jan 2005

NickyK- For what it's worth I had a similar problem and like you- resolved it by re-installing SP-2. I believe my problem was caused by a worm called "skq" which finds its way into your System32 as an .exe and changes file associations.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?