Windows drivers

  Cluelessone 12:46 01 Jan 2008

Ladies and Gentlemen Happy New Year!
Would appreciate your thoughts on this one.

This problem started as an Ipod snag, but I’m now becoming convinced that it’s more likely a Windows (XP/sp2) error. Here we go:

New Ipod isn’t recognized by windows. Device manager lists it as Ipod with an exclamation mark and the note “The drivers for this device are not installed. (Code 28) To reinstall the drivers for this device, click Reinstall Driver.” Taking this step has effect.

Said Ipod works quite happily with my laptop and is fully up to date.

Itunes on both computers is the latest version.
My older Ipod is recognsed happily.

Different USB leads and ports make no difference.
All other peripherals work fine except……..a relatively new Panasonic camera which when connected by USB produces the same error. When I offer it the driver on CD though, it states that it cannot find the necessary software?!

I’m now thinking along the lines that maybe Windows driver database is corrupted. What do you think?

  Fruit Bat /\0/\ 12:52 01 Jan 2008

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB, reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

Repair XP by replacing corrupt files

sfc /scannow

in the run box, press enter and let system file checker find and replace missing / corrupt file in windows and explorer.This will take awhile to complete and you may be asked for the CD to be in the drive if windows is not preinstalled on the hard drive.

sfc /scannow problems
click here

  martjc 12:57 01 Jan 2008

...Run a thorough anti-spyware scan, then defragment the HDD.

Remove the ipod from your machine.

After the scan, go to [Start], control Panel, System, Hardware, Device Manager.

Next, remove ALL the usb drivers. (Don't worry, Windows will re-install them after the next step.)

Re-boot the PC.

After seeing the 'Found new hardware wizard' completing, plug in your ipod and try again.

If you still have problems, post cack with the result.

Good luck.

  martjc 12:59 01 Jan 2008

...Fruit Bat posted at same time. Follow his further advice

  crosstrainer 13:03 01 Jan 2008

Try the latesr drivers from:

click here


click here

  the real Ali G 14:05 01 Jan 2008

I had this problem with various usb devices for months and tried all these things that people advised with no joy. Even restored my PC to original factory settings. Then I came across this solution which worked for me so I hope it works for you. Basically it was 'permissions' thing in the registry that needed changing.
Open the registry editor: Go to Start,Run and type in regedit, then hit ok.
Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB. Right click on the folder and pick permissions. Set to ALLOW.
Do the same for: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

I'm no expert so it may be worth waiting for some responses to this from some of the more experienced guys here before actually doing the above.

Good luck

  Cluelessone 14:20 01 Jan 2008

Thanks for your responses so far.......

I was following fruitbats guidance and was uninstalling USBs. One of the first was my logitec cordless keyboard and mouse (Der....)
On restarting I [email protected] use the keyboard and mouse and no ammount of efforts to reconnect will work. Windows says it has found the new hardware but is waiting for a mouse-click from me to search for drivers (I assume)So I'm now stuck! No hardwired USB mouse at hand and it's new years day......

Maybe I should have posted on "absolute beginners???!!"

  andy_b_73 14:28 01 Jan 2008

Press Alt+Left Shift+Num Lock all at once and a prompt will appear telling you that you have activated mousekeys, select ok then you can control the mouse with the numpad.

The controls are:
1,2,3,4,6,7,8,9 = move the mouse
5 = mouse button click
+ = double click
insert = hold down mouse button
delete = release mouse button (after holding it down with insert)
/, * or - = select which mouse button the above controls will click (left, both or right respectively)
numlock = disable mousekeys

  Cluelessone 14:33 01 Jan 2008

Thanks mad monk, but the keyboard is wireless too....

  the real Ali G 14:41 01 Jan 2008

Same happened to me and I had to borrow a PS2 keyboard and mouse. Then when the pc searched for the drivers and started loading them I got an 'invalid data' message, which turned out to be because of the resistry permissions.
So if you have problems with re-loading the drivers edit the registry as advised above.

  Cluelessone 11:21 02 Jan 2008

Tried a corded mouse. No joy.

Everytime I start up I get

"Found USB controller (x2)Found PS/2 USB mouse"

"Found new hardware wizard-Windows will search for updated software by looking on your computer, on a CD or on windows update website....Can I connect to windows update to search for new software?....

.Yes this time only
.Yes and every time I connect a device

Click next to continue...."

And of course I cant click on anything because my keyboard and mouse(s) arn't working!!!!

Pleeease somebody HELP

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?