Windows Delayed Write Failed

  AlanHo 12:09 03 Mar 2007

I have been struggling with a frustrating problem with my computer for the past 5 days.After an interval of about an hour after re-booting from cold each day - I keep getting pop up error messages from the task bar telling me :-

"Windows Delayed Write Failed".
Windows was unable to save all the data for the file E:$BitMap.
The data has been lost.
The error may be caused by a failure of your computer hardware or network connection.

It is not always the same file name that pops up - sometimes it is a file on the F: drive named F:$Mft - at other times it is other file names. An Explorer search of my hard drives has failed to find any files of similar names - even including hidden and system files - with or without the dollar sign.

I have two internal hard drives - each divided into two patitions. The first hard drive has C: for the OS and programmes and D: for data. The second hard drive has two partitions used for back-up purposes E: and F: so the problem is occurring on just this hard drive.

Once the problem starts the error messages keep popping up and no matter how many times you click to delete them - they keep coming back. The computer will not shut down normally - the error message intervenes and the only way to close down the computer is to use the reset button or power switch - which is a bit drastic but necessary.

Yesterday, after a forced reset, the computer refused to reboot showing a message NTLDR is missing Press Ctrl+Alt+Del to restart. Doing this only resulted in the message returning and I was stuck in a loop.

I tried to boot from my Acronis emergency boot disc but this didn't work and I eventually opened the BIOS - to find that the boot sequence was all screwed up. I put this right and the computer rebooted OK. I assume this was the result of having to switch off the computer incorrectly.

Using explorer I can browse the E: and F: drives without a problem and can save, move and delete files at will. There is no thus no firm evidence of drive failure and the drives are not making any unusual noises.

Yesterday I did an Acronis disc image restore of my C: and D: drives back to a week ago when all was OK - it made no difference. So last night I decided to check the drives using the windows facility in explorer, right click drive, properties, tools, error checking, selected "Auto fix file system errors" and "Scan for and attempt recovery of bad sectors".

Drive F: was checked OK and showed no errors but drive E: stalled part way through after running for about an hour. I rebooted the computer and tried again - this time leaving it checking overnight. This morning I found it had stalled again in the same place with about half the little green progress bars showing. Hence the E: drive check is not completing.

I have googled for solutions and found a solution in MS knowledge base 330174 which suggests I cancel "Enable write caching on the disk" - but I am unable to do this because the feature in the disk policies tool is greyed out.

Other solutions found via Google have also proved ineffective.

Any ideas anybody...?

  brundle 12:30 03 Mar 2007

Check the drives again with the manufacturer's diagnostic - click here

  AlanHo 23:29 04 Mar 2007


Thanks for the link - it confirmed my worse fears - the drive is dodgy and I must replace it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?