Windows CMD line characters

  [email protected] 21:18 17 Feb 2012

How to input a Tilde "~" in the Cmd line. It's Shift # on my UK k/b but it doesn't work and it's Alt Gr 2 on my French k/b and that doesn't work either :-(

  Fruit Bat /\0/\ 21:41 17 Feb 2012

It's Shift # on my UK k/b works on mine

sounds if you have yours set to US

Control panel regional settings and languages - set everything to English UK - you may need to reboot for it to take effect.

  [email protected] 21:56 17 Feb 2012

Thanks Fruit Bat /\0/\ Hmm, I would if I could. I am actually trying to run a cmd line on a PC which won't boot. I am using repair console to run the cmd line. I have a few other k/b's lying around so I'll try them as it would appear to be a k/b issue.

  Fruit Bat /\0/\ 22:21 17 Feb 2012


try the key to the left of 1

  [email protected] 13:51 20 Feb 2012

Hmmm. That gives me the square root little 2?

  [email protected] 14:01 20 Feb 2012

Found it: Alt (hold) 0126 on the KeyPad.

  [email protected] 14:31 20 Feb 2012

:-( Nope, not that either. Getting a capital Z before the ~ now, which rejects the input line.

This is the line I am trying to input:

C:\Windows>CD C:\system~1_resto~1

I am using XP Repair console to try and boot up a dud system from a restore point. Maybe the spacing is wrong as it's not easy to see from the example? (Now I can't find the site which gave the example but I have each step written down. Basically it's a cmd to list the restore points, find the 2nd highest number then carry on from that)

  [email protected] 14:47 20 Feb 2012
  [email protected] 17:04 20 Feb 2012

Gets worse. When I run Repair Console it seems I should be asked which system I want to repair (typically #1), and when selected I should end up with a cmd line which begins "c:/windows" I'm not given the option to choose anything but go straight to a cmd line which begin "c:>" Any MS-DOS buffs out there can tell me what's up?

  Batch 22:03 20 Feb 2012

Can't you just type:

cd windows

to get to C:\WINDOWS>

Or maybe there isn't a WINDOWS folder......

  [email protected] 09:51 21 Feb 2012

Thanks Batch. I just tried it and got the response "the path or file is not valid". Beginning to think there isn't a WINDOWS file like you suggest... I've tried running CHKDSK but that stops halfway through with an error message. Oh well, it was just a learning challenge to try and bump start one of my wife's old computers. I have mounted the HDD in a spare PC but I am unable to read from it. I get the message that it's not formatted! Not pointing any fingers but it was OK until McAfee Remote Technician took over the PC to sort a problem last year. May just be coincidence but it never worked properly afterwards and just got worse until it wouldn't boot at all - and that's where I came in. Of course it could have been the HDD failing or any number of things. With my "C:(backslash)>" line, it's like I can only use input from a list of pre-prepared commands. If Self~Destruct was listed I may have tried it by now :-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?