Windows can see Firewire but won't see any devices

  Michellangelo 11:06 12 Feb 2008
Locked

Hi folks!
I've got a rather weird problem> Until 4 months ago I've had a perfectly working Firewire card on my computer. I could transfer DV video from and to my camcorder via Adobe Premiere Pro, a powerful video editing program. What happenned next is going to leave you with some very strange and ununswered questions:

Few months ago I've tried to connect my Firewire card with my DVD recorder (via a firewire cable)so that I could playback edited video in Premiere Pro and directly record on the DVD recorder (I needed this as an urgent solution because I didn't have time to wait for rendering). Nothing. Windows wouldn't detect any device.

I said "fine, no probs, I'll export the video back on the tape in my camcorder" so I've plugged my camcorder back into the Firewire card on my computer. At that moment a chill rushed up on my spine: Windows wouldn't detect the camcorder.

Of course, the first thought was "Oh God, I've fried them". After few deep breaths I came back in the room and started doing some boleean logic:

1.Connect camcorder to DVD recorder via firewire - PASS => DVD, camcorder & cable are ok

2. Restart Windows and connect camcorder to my Firewire card via firewire cable - FAIL

3. Chect the status of my Firewire card in Device Manager - PASS

4. Try to plug in my Compact Flash Firewire card reader - FAIL => the Firewire card on my computer is faulty

5.Went to the local PC World and buy a brand new Belkin Firewire card and install it on the same PCI slot, then reconnect the camcorder. Windows still wouldn't see my camcorder.

6. Check again BIOS config, but since I haven't got a motherboard with native firewire support, there is nothing to change.

7. Check again the Device Manager, my Firewire card shows perfectly, no conflicts, the card is enabled, the OHCP compliant device shows up, latest drivers installed from Belkin.

8. Change the PCI slot of my Firewire card and try again - FAIL (meaning the card shows up fine in Device Manager but Windows wouldn't detect any device connected to that card.)

9. Looking all over internet for a solution (including ALL Microsoft knowledge base about Firewire problems) - FAIL (nothing relevant found, same stupid questions "Are you sure you've plugged the device?" etc.)

10. Asking you guys to help me out here. WHAT ON EARTH IS GOING ON WITH MY CARD??? I'm not a beginner in computers, so an "expert" answer would be more then welcomed instead of the regular "check-up questions" before posting an "I don't know what's the problem mate".

Many thanks and I hope some of you will figure out a solution to this problem which is troubling me for the last 4 months.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?