Windows 8.1 - can't reinstall WLAN driver

  onthelimit1 22:21 18 Jun 2014

Have a Sony VAIO that would not connect to internet. Uninstalled the device and downloaded the correct driver from Sony website. When I try to run the prog I get -

'You do not have access to make the required system modifications. Please rerun this installation from an administrators accout'.

Account is the only one one the laptop. Guess it's a permissions problem, but google little help.

Any bright ideas for me to try in the morning, please?

  onthelimit1 22:47 18 Jun 2014

Ah - just found a Vaio update app on the laptop, and that seems to be by-passing the problem. Will leave it to run overnight.

  onthelimit1 08:19 19 Jun 2014

All updates installed except the WLAN which failed.

So, how can I overcome the problem of permission?

  onthelimit1 09:44 19 Jun 2014

Overcame this problem but running the installer in safe mode. However, still no WLAN device showing in Device Manager

  Jollyjohn 13:39 19 Jun 2014

It would suggest the WLan hardware has failed.

Boot into BIOS and ensure the WLan device is enabled then look again in device manager.

(do double check you haven't switched wlan off, I think it is FN+F1 on a Vaio)- this is doubtful as I would still expect to see the device in device manager.

The next step is to open the back of the laptop and physically check the wlan chip is seated properly.

  onthelimit1 16:48 19 Jun 2014

Thanks jollyjohn - had to strip the lappy to get to the minicard (unlike most where they are under a hatch). Tried reseating with no change. Found an old broadcom minicard (different number to the Sony one) - plugged it in and it was recognised in DevMan straight away. Have found the correct one on ebay for a tenner, so all should be OK.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?