Windows 7 hard disk problem message

  tallboy 19:19 02 Jan 2010
Locked

I have a new 64-bit Windows 7 PC with two 1TB Samsung HD103SJ ATA disks in it (Non-RAID). I am regularly getting a Microsoft Windows error message (i.e. At least once a day) saying 'Windows detected a hard disk problem, Back up your files immediately to prevent information loss and then contact the computer manufacturer top determine if you need to repair or replace the disk.'

It goes on to give me two options; 'Start the back up process' or 'Ask me again later'

I have my drives backed up onto an external hard drive using both Windows back up facility and Acronis True Image Home. On the PC I have Ashampoo HDD Control and EnhanceMySe7en disk-checking apps and both of these report that the performance on both disks is in excess of 99.6% using S.M.A.R.T.

I guess it is just feasible since both disks were manufactured at the same time (there is just a few digits difference between the two serial numbers)that they are suffering from a minor manufacturing defect on the platters.

What tests can I run to fully check all the sectors on the disk and to move data off and then mark & bypass any 'doggy' sectors?

All suggestions welcome. Thanks.

  T0SH 20:40 02 Jan 2010

Check on the samsung web site (support section) they should have a downloadable (or a recomendation for one) drive test utility use this carefully (as it can be used to zero fill drives) if in doubt quit and start over

A disk test from right click Properties on the drive then Tools tick both the boxes will scan and fix any bad sectors but it will take a long time with large drives

Cheers HC

  T0SH 20:55 02 Jan 2010

Having read your post again, I think the alert you are getting is from the Win 7 drive backup utility trying to get you to create an image maybe doing so to an external drive would shut it up and stop the alerts ?

There must be a setting to turn it off somewhere though maybe just requires a good dig around to find it

Cheers HC

  tallboy 21:54 02 Jan 2010

Thanks for the quick response Tosh. Like you, I though that creating an image might make it go away - but it didn't! I'll run a disk scan tomorrow and see if that throws anything up. I'll also take a look at the Samsung support web pages to see if they offer any drive checking utilities.

Incidentally, I just ran a 'deep' scan using Malwarebytes Anti-Malware program. This threw up a couple of items (one in Systerac Tools for Windows 7 and the other in the registry key for Explorer Current Version Policies) but I don't think these would be the cause of the problem.

  Eargasm 23:05 02 Jan 2010

I have a mate who is getting the same error messages since moving to Windows7, and a Google seems to show there are many others with the same problem.
His computer is running fine apart from that message, and i feel it is a problem with Windows 7 rather than a failing hard drive.

I have found a few things to try from Microsoft Support.....

Hello
Welcome to Microsoft answers

(A). Try these steps and check if it helps.
1. Open Group Policy Editor - i.e. execute gpedit.msc
2. Navigate - to the following setting
local computer policy-computer configuration-administrative templates-system-troubleshooting and diagnostics-disk diagnostic-disk diagnostic: configure execution level
3. Double Click or Properties on this value and set it to disabled. nb.
Not configured is enabled by default.
4. Close the Group Policy Editor, no reboot or reset of services is
required. Any Disk / Smart related errors will now simply be written to the log
with the end user not given various popups on corrective course of action.
5. I hope that this help you overcome this problem. This would be the best approach. It would allow you to identify the root cause of my connectivity issues.

(B).If this doesn’t help then try disabling S.M.A.R.T in the BIOS for which you need to contact manufacturer of the Computer.
BIOS DISCLAIMER:
Modifying BIOS/complementary metal oxide semiconductor (CMOS) settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of BIOS/CMOS settings can be solved. Modifications of the settings are at your own risk.

  tallboy 14:56 03 Jan 2010

Well, the fact that I am 'not alone' with this problem is somewhat comforting! However, it would be more re-assuring if Microsoft eliminated this 'bug' altogether.

Many thanks for the info from Microsoft Answers Eargasm. I have changed the setting in the Group Policy Editor, so I'll monitor the disk failure warning over the next week (hopefully there won't be any) and post the outcome here for the benefit of other readers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?