Windows 2000 display adapter problem

  andy625 12:11 29 Dec 2005

I have a p3 600 running windows 2000, and I have had problems getting windows to register what the display adapter is - see click here

It turns out that the adapter I had (rage 128 pro 32m sdr) is not picked up by windows 2000. I tried downloading all the different types of driver listed on the ATI manufacturers website, and none of them work. It just says I havent got the right hardware.

In desperation I took the display card out and fitted another card from an old p100 machine. Now when I boot the windows 2000 machine, it hangs in the bootup process. If I start in safe or safe with vga mode, and go to the control panel it has registered the new card, but it wont let me boot up properly.

When I put the replacement card in, it was a different size to the original (slightly longer and different pin positions on the edge) and wouldn't fit into the originals slot on the motherboard, so I put it in one of the other slots, into which it fitted ok.

Is there any way I can get this to work, or do I need another display adapter the same size as the original so that it will go into the original slot? What is the difference?

  andy625 19:09 29 Dec 2005

No-one know anything about this???

  Skyver 19:13 29 Dec 2005

Was the P100 card an ISA model? Not sure about 2000 but I know XP (which is very similar to 2000) doesn't support any ISA hardware. click here

  andy625 00:15 02 Jan 2006

The graphics card from the P100 (from memory - its late) was a S3 something or other. It doesn't have any yellow warning symbols next to it in device manager anyway.

  Skyver 00:40 02 Jan 2006

Perhaps you're in luck in that case. It's not something I've ever come across with Win2k, it's always worked fine with a variety of hardware and video cards for me, from ancient S3 jobs like your one to a Geforce3 TI200 (only PCI and AGP though, never had cause to try an ISA card).
Does the original card show up correctly if you use a DOS based hardware detection program like this one ? click here
Is this a fresh install of Win2k or upgrade from an older OS? I take it everything worked fine until Win2k was installed.

  Skyver 00:46 02 Jan 2006

I'll wager your original card was AGP and the S3 is PCI. Just checked your old post, re-install of Win2k I see - can you get any more information off the card itself, does it have an FCC-ID number? Of course it should work fine with the proper chipset drivers from ATI but maybe it needs drivers from the specific manufacturer. Try turning off any extra hardware in BIOS and see if that frees up some resources. Look for a setting relating to IRQ/VGA - `Assign IRQ for VGA` or something similar and switch it on. If it gives you a choice of IRQ just go with the first one. What is make/model is your motherboard?

  andy625 13:24 02 Jan 2006

This is the spec/type of motherboard etc (cut and pasted from the Belarc report):

ASUSTeK Computer INC. P3V4X REV 1.xx
Bus Clock: 133 megahertz
BIOS: Award Software, Inc. ASUS P3V4X ACPI BIOS Revision 1003 03/14/2000

New graphics card (from P100 machine):
S3 Trio32/64 [Display adapter]
Default Monitor

Original graphics card:
Rage 128 pro 32m sdr
fcc id: pqb-r128-p102
p/n 1024-0102-01-am
s/n 201002626
pcb no. 35-s102-g0-01

600 megahertz Intel Pentium III
32 kilobyte primary memory cache
256 kilobyte secondary memory cache

256 Megabytes Installed Memory

Standard floppy disk controller
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller]
VIA Bus Master IDE Controller

The pc was originally my work pc, that I used with Windows 2000 for cad work. There were no problems with the display then, but I was using a 21" monitor. I have reformatted it and first installed XP (with which the monitor seemed to be ok), then due to the processor being maxed out all the time, I wiped it again and put on 2000.

I'm not very confident about messing about with the bios, so if you think I need to do that I may need more detailed instructions if poss.

At the moment I have the thing running in vga enabled mode using the p100 (S3) graphics card. When I run belarc or device manager it says that it is installed whereas the original graphics card didn't register at all (ie no make/type listed).

  andy625 08:53 03 Jan 2006


  Skyver 23:47 03 Jan 2006

This is really hard to diagnose without sitting in front of the machine in question - I have a friend I built a PC for years back, with the same board, P2-400, S3 PCI and Voodoo2 if I recall, and I think I may have used that board with an early AGP card but I can't be sure. There are no issues with P3V4X and any AGP cards on the ASUS site, but in addition to posting here you may get some answers from the forum there click here
If I were able to see the machine itself, the first thing I would check is BIOS settings - if I get to check out the machine I mentioned soon, I'll take a look through the BIOS settings and see if there are any pointers there.

  andy625 09:22 04 Jan 2006

Thanks for your help skyver. I "borrowed" a maxtor AGP display card from work yesterday and tried that in the machine. It booted up ok initially with 16 colours. I downloaded 2 versions of driver from the maxtor site and with both of them when I rebooted to finish the installation, the monitor turns itself off, and stays off! The power light goes out as if the supply has been disconnected!

If I start up in VGA mode as with the other cards, it boots up. I went into the bios and found a vga setting which was disabled, changed that to enabled and it made no difference.

I'm pretty sure its a problem with the machine as I have tried 3 cards now. All of which work when started in VGA mode, but not in normal bootup. The annoying thing is that I know it was running W2000 before when I used it at work, with no problem. I used it as a CAD station for 2yrs.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?