Window USB port connected to an External Hard Disk

  troyless 10:03 08 Feb 2004

have tried to connect an IOMEGA 80MB External Hard Drive (HDD) to my Evesham XP computer (purchased in April 03) via a USB Port but the HDD is not recognised and does not appear within 'My Computer' window.

The 'New Harware Detected' wizard appears but on activation it does not seem to be able to find the required driver.
In the 'Computer Management Window' a yellow ? and ! is displayed alongside the item 'External Hard Drive'. No other problems are evident (Conflicts etc). A Code 1 is also displayed in the PROPERTIES window

I have tried all the advice given at the IOMEGA internet site for this problem but nothing seems to work.

I think I have established (may be?) that the driver required is a microsoft driver called USBSTOR.SYS. When I first looked in C:\WINDOWS\SYSTEM32\DRIVERS this file was NOT present. I therefore extracted this file from C:\WINDOWS\I386\SP1.CAB to the DRIVERS folder still no joy - it could still not find the driver.
I then added this file to a floppy to see if the system would detect the driver still no joy.
Also tried inserting the original SP1 Windows disk - no luck.

The USB chip set is made by VIA. I have also downloaded the latest USB drivers using Usoft Update facility.
I know the External Hard Drive is OK as I have connected it to both a Windows XP m/c and another running ME.
I have another USB device attached to another port & that is OK (Also disconnected this in case there was some kind of conflict).

Any help would be much appreciated!

  spruce 10:13 08 Feb 2004

You have probably already tried this, but try all the combinations of jumper settings on the hard drive, master/slave/csel/no jumpers.

Have the computer restart rather than plug when switched on.

Have a look in the disk management tools when the computer is booted, it is not uncommon for a drive to be seen in disk mangement and not be seen in windows explorer.

Also where are you getting the power for the cradle, is it self powered, a powered hub, direct from the usb port.

Just a few things for you have a look at, hope this helps.

  troyless 17:27 09 Feb 2004

Thanks Spruce
The external hard drive does not have the jumpers referred to (although they may be inside the unit). Tried computer restart when disk is already connected - but no joy.

Power comes from external power source (mains driven)supplied with the External Drive.

No the Hard Disk is listed in Device Manager but with yellow ! & ? - not listed under Windows Explorer or under Disk Manager.

  keenan 00:58 10 Feb 2004

Sorted a similar problem recently with a Seagate Ext HDD and using a 'powered' usb hub cured the problem.

Try temporarily disconnecting non-essential usb devices and try again.

Some further help click here

  troyless 11:58 14 Feb 2004

Thanks Keenan
But this external drive has its own Power supply? No easy access to a Power Hub.
Tried disconnecting the only other USB device - no difference.

  Diemmess 12:10 14 Feb 2004

Similar trouble with an Amacom HD which also has its own power supply.

Phoned their tech line.......... Their advice was have the computer running first, then plug the HD in, and then when asked, install their software.

In the past, have found Iomega phone (live, human,) helpline both patient and truly helpful.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

Black Friday Deals for Designers & Artists: Adobe, Apple, Corel Painter, Microsoft Surface, Wacom &e…

Best Black Friday Apple Deals 2017

Black Friday 2017 : date, sites participants & bonnes affaires