Win2k shutdown - it doesn't

  Bargee 10:46 29 Feb 2004
Locked

Hiya,

Just installed Windows 2000 pro on my new build & it won't shutdown, re-booting all the time even after setting power management to hibernate. This according to windows is supposed to eventually shutdown the computer. Holding down the power button works ok, but obviously its not ideal.

Can't find anything in BIOS (Award) to give me a clue so haven't altered anything there.

Checked out the PC Advisor forum history, but no joy either.

Anyone give me a clue?

Cheers.

PS, I'm running 2 PCs through a KVM switch in case this might be a factor, although the other PC seems to shutdown ok in Win98SE.

  wobblymike 11:40 29 Feb 2004

I had a similar problem, open up device manager select view, select show hidden devices, scroll down to NT APM Legacy support and open it double click on NT APM Legacy Interface node and then disable it.

Shut down your PC, if it shuts down to "It is now safe to turn off your PC" this indicates that your PS is not configured to automatically shut down.

Hope this helps

Mike

  Bargee 17:32 29 Feb 2004

I'll go for that right now, cheers.

  Bargee 17:47 29 Feb 2004

There is nothing on my Win2K device manager that shows anything with the prefix of NT & the only items marked Legacy are audio drivers & video capture devices.

Perhaps the info lies elsewhere or that could even be the problem itself - NT Legacy Support is missing entirely.

  wobblymike 17:55 29 Feb 2004

YOU HAVE TO VIEW HIDDEN FILES IN DEVICE MANAGER

  Bargee 19:42 29 Feb 2004

I followed your suggestion to the letter. I even tried all the different "view" options - zip.

  temp003 03:37 01 Mar 2004

Agree with above the first thing to check is Power Management. To use w2k, it is recommended that your computer supports ACPI or at least APM.

The power management features may show up in Device Manager in the item Computer, or in System Devices. Whether you can enable or disable anything from there, I don't know.

Go to Control Panel, Power Options, go through the tabs and see if you have a choice for enabling or disabling APM or ACPI. Try changing the setting.

Another place to look is in BIOS, power management options. What options to select depend on the computer itself, and it's hard to say, but just try changing the settings. But please remember the original settings so that you know what to restore to if necessary.

If in BIOS you have a choice of either ACPI or APM, try enabling it. If you have both, try enabling one and disable the other (if both are available, ACPI should be preferred to APM).

The choices are confusing because enabling APM has solved many shutdown problems with new XP (similar to w2k) installations.

But then, some time ago I installed w2k on my niece's computer (which previously had 98). It had shutdown problems (W2k shut down but did not power off). In her BIOS, she had both ACPI and APM available. Disabling APM solved her problem.

  temp003 04:10 01 Mar 2004

If power management can be ruled out as a cause, then you should check startup applications and device drivers.

The restarting instead of shutting down means there's a fatal error during shutdown. W2k, like XP, is set to automatically restart on fatal errors (which skips the BSOD). Right click My Computer, Properties, Advanced tab, Startup and Recovery, System Failure, untick the box "Automatically restart" and click OK, OK. Next time you have a shutdown problem, instead of restarting, you'll see the dreaded BSOD, but then you can write down the message which, if you're lucky, might indicate the source of the problem (but more often not).

To see previous shutdown/restart problems, go to Control Panel, Adminstrative Tools, Event Viewer. Against the System Log, double click the red crosses errors, and you'll see a description of the problem. But the information may not be comprehensible (this is what you will see on the BSOD).

Startup - certain processes are running even though you are not using the applications, when you shut down. Disable all startup items except those necessary to run w2k (keep mobsync), restart, and try shutting down. If the problem disappears, you need to re-enable the items one by one until the problem reappears, then you know which one is causing the problem.

w2k does not have msconfig so download and install Mike Lin's Startup Control Panel 2.8 from click here Go to Control Panel, Startup and go through each tab to untick unnecessary items.

If you want msconfig, you can use the XP version which works perfectly with w2k (but Mike Lin's better) click here and underneath the screenshot, there's a word "here" and that's the link to the download. Unzip the download, and copy msconfig.exe to the folder C:\WINNT\system32 folder (if fresh install) or to C:\WINDOWS\system32 if it's an upgrade from an older Windows. You can then run msconfig from Start, Run.

[You will want either or both downloads anyway. I would use Mike Lin's for managing startup and msconfig for its other tabs.]

Otherwise click here for troubleshooting shutdown. This page is for XP, but they don't have one for W2k, but w2k is closer to XP than any of the 9x OS's, most things will apply to w2k. The site also has other useful information about shutdown.

  Bargee 20:15 01 Mar 2004

Well, temp003, I've followed the suggestions & come up with the following:

My BIOS only has an ACPI dump to RAM option which is either enabled or disabled - disabled is the default & the setting proved irrelevant.

In Admin Tools, I found the error;

PADUS ASPI SHELL
Service failed to start due to the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

After unchecking Auto Boot, I got the folowing Blue Screen error message on shutdown which I've copied down in full:

*** Stop: 0x000000D1 (0x00000014,0x00000002,0x00000000,0xEB418DAB

*** Address EB418DAB base at EB418000,DateStamp 3D7903e1 - nv_agp.sys

Both lines stretched across the full width of the screen unlike here. I think this could be a driver error with the onboard nVidia chipset, but I'm guessing.

Meanwhile I'm going to check out
the troubleshooting link before I do attempt any changes

  temp003 08:01 02 Mar 2004

Found on the internet similar stop errors referring to nv_agp.sys in the context of XP (but would be the same in w2k). This is the motherboard nForce2 AGP controller driver. Most of them are resolved by using a different version of this driver.

But found this in particular, click here where even the numbers and parameters in the error message are the same (first time I've come across the exact error on a search).

Don't get your hopes too high yet as these stop errors are never easy to resolve.

I would go to the motherboard website or nVidia website, to get a new set of drivers for the motherboard. Download it to your computer and have it ready.

Then go to Device Manager, expand System Devices, and find something like "nForce2 AGP Host to PCI Bridge". See if there is a yellow exclamation mark.

If you don't see the item, try clicking View, select Show Hidden Devices.

If there is a yellow exclamation mark, and you haven't installed motherboard drivers from the CD, try installing them from the motherboard CD, for w2k.

If you have already applied the motherboard CD, then whether or not there is a yellow exclamation mark, right click the item and select uninstall. Restart. On restart, see if w2k can install the right driver for it. Check in Device Manager. If there is no exclamation mark, try shutting down. If on shutdown, you still get BSOD, start again, and apply the newly downloaded nVidia drivers set.

If there is a yellow exclamation mark after uninstalling and restarting, apply the downloaded drivers set.

Another possibility is downloading and installing SP4 for w2k, which may have the MS signed driver for nForce2, then in Device Manager, try selecting update driver for the item, and let Windows find an appropriate driver, and see if that works.

Ultimately, it's a question of finding a version of the driver that would work.

  Bargee 10:26 02 Mar 2004

I'll check these things out, but in the meantime, There has appeared another line on the blue screen in between the 2 I've already given, it is:

DRIVER_IRQL_NOT_LESS_OR_EQUAL

The only reference I've found on the XP link that shows this type of message is also followed by what appears to be an address line/code.

Ta for now.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?