win xp recognises usb printer on lpt1 port only

  ableseas 11:44 22 Sep 2006

Hi folks, Wondering if you can help a colleague of mine.He has a problem with his epson c40 plus(usb) printer connecting with win xp home.This printer was working perfectly until his automatic updates updated his pc.My colleague has also tried his printer on his sons pc running win xp home since,with no problems.Obviously he has not been able to print anything because windows doesnt recognise the presence of the printer on any of his usb ports.Windows,however does appear to connect the printer to his LPT1 port for some reason.
Uninstalling all relevant usb driver files etc to do with this printer and re-installing the printer from fresh makes no difference whatsoever.
Any suggestions please.Thanks in advance to your reply's.Steve :)

  Digital 11:55 22 Sep 2006

Has your colleague tried going back to a Restore point before the update?

  ableseas 11:59 22 Sep 2006

Thanks for your reply.I asked my colleague the same question.He says his backup restore doesn't work for him.

  James. 12:02 22 Sep 2006

Heres what I would try, disconnect the usb cable from the PC, uninstall everything to do with the printer, all drivers and software. Download cCleaner from click here and run the registry clean up facility, reboot the PC and re-install the software/drivers for the printer, waiting for the instruction during install to connect the usb cable.

  zarobian 12:29 22 Sep 2006

James suggestions are spot on. After reinstallation as suggested please check the following:
Go to Start-->and select Printers & Faxes. Right click on Epson Stylus C40 (where you will find a check mark). Click Properties and then from the properties page select PORTS.
Make sure that you check the USB...Virtual Printer port instead LPT1.


  ableseas 19:31 23 Sep 2006

I'll forward your suggestions to my colleague James and Zarobian.I have a feeling he has tried your suggestion James,never the less I'll forward it anyway.Thanks again for you help people.

  ableseas 17:57 26 Sep 2006

Hi Folks,My colleague has tried your suggestions but no joy I'm afraid.
When trying out 'zarobian's'idea there is no usb virtual printer port showing in his 'ports' properties section what-so-ever.
My colleague even connected another known working usb printer with exactly the same results(to be expected I suppose?)
Any more idea's please before my colleague thinks about re-installing win xp??
Thanks again.

  ableseas 19:53 29 Sep 2006

Has no one got any good suggestions to help solve this problem?(Pretty Please):)

  De Marcus™ 20:16 29 Sep 2006

Uninstall USB from within device manager and reboot. Windows will automatically reinstall the correct drivers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?