Wifi works for some devices but not others

  aedoni 12:18 21 Feb 2016
Locked

Hello there - having trouble with wifi over a BT Broadband connection using Home Hub 4. Some devices connect to the wifi, mainly over the 5 ghz channel, while others don't. The 5/2.4 ghz channels have been split to separate ssids and channel numbers changed, but problem remains - all that changes is which device can or can't connect. The only device that has always connected without problems is the iPhone 6. The broadband connection has been checked and is fine. The router has also been replaced. This suddenly started happening about three months ago - wifi was stable before that.

Additionally, about the same time two power line plugs started to have intermittent connection problems. I've just replaced these and they seem to work for now, but I can't help wondering if this is somehow all connected to the wifi problem.

Any help or advice would be much appreciated.

  Govan1x 12:47 21 Feb 2016

Disable the 5ghz and just use the 2.4 Ghz. Works fine for me.

  aedoni 18:48 21 Feb 2016

Many thanks, Govan1x - I just tried this and the wifi connected to all devices, plus the new home plugs that were working but stopped an hour after I posted also had their connection restored. Is there a reason for why this should be the case? The wifi on both channels was fine for two years...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?