wifi connection of PC- can someone help me

  wildone 11:21 09 Dec 2009
Locked

Hope someone can tell me what to do?

We've got a dlink asdl2 wifi router working fine. Also a time capsule running into it.
Two macbook pros running on it fine. They choose either the dlink or time capsule to run through depending on strength.

Upstairs, two PC's running XP on it, both get full signal and run fine. All internet works etc.

Lastly I have a PC in loft with slighter weaker signal which up to weeks ago has always been fine. Now it gets signal but doesn't load the internet.
I may have caused the problem by trying to change settings so that the PC could print from our printer downstairs that is connected to the time capsule. The macbooks do this fine.

Now I can't get the internet any more.

I have tried all the obvious stuff like rejoining networks, swapping networks, redoing the passwords, turning router on/off and I've checked that the options use windows to connect is checked etc.

Can anyone tell me what to do, I'd greatly appreciate it. I've read many blogs where macs connect and not PCs or the other way round etc but here it must be something to do with just that one PC

Cheers W

  gary2112 12:36 09 Dec 2009

try this in windows go to the dos promt and type ipconig /all
if all is working you shoud get a number
then type this ipconfig /release
then ipconfig /renew

  wildone 18:27 09 Dec 2009

Thanks for help
When I go to dos prompt & type ipconig/all

it says ipconig is not recognised as an internal or external command

What next?

Cheers W

  wildone 18:32 09 Dec 2009

Ok I see it was a typing error so I did exactly what you said ipconfig /all and the numbers came up etc but still not getting internet although signal pretty strong

Cheers

  woodchip 19:20 09 Dec 2009

Have you tried changing the Wifi channel in the Router?

  wildone 21:18 09 Dec 2009

Not sure what you mean here.

On any computer in the house you are offered two networks either the dlink or the time capsule . Depending on which is stronger I choose whichever one.

The two macbooks are on the time capsule, the two pc's are on the Dlink and the third which has the problem tries on the dlnk.

I have swapped to the time capsule but no different and I've checked the network key & password. It's definitely picking up the network but explorer, firefox or safari just don't load the pages.

Is this any help
Cheers
W

  woodchip 21:54 09 Dec 2009

If you use your Browser to enter the Setup Page in the router under Wireless you should have channels 1 to 11 you can pick any to try but start round about 7

  wildone 12:41 10 Dec 2009

Hiya woodchip,

I'm not sure where to start, I have looked for a set up page but I'm obviously looking in the wrong place. Would you be so kind to point me in the right direction. I do have the wireless connection window with various addresses, numbers, protocols etc but no set up or channels ?

When you say browser, do you mean explorer because I've tried there and also the wireless icon at the bottom that tells you the status etc

Thanks for the help so far

w

  mgmcc 19:44 10 Dec 2009

Type the *ROUTER'S* IP address (probably 192.168.0.1 or 192.168.1.1) into your web browser and this should open its configuration pages. You will be prompted for the router's Username/Password - the Username may be "admin" with no Password set.

  wildone 00:06 11 Dec 2009

I tried this but no luck, I also reloaded the usb wifi aerial software and also made sure local area connection was switched off and checked passwords.

Any more ideas?

w

  mgmcc 08:18 11 Dec 2009

When accessing the router to change settings, you should do so with a *WIRED* ethernet connection, not "wirelessly". You should not therefore have "switched off" the Local Area Connection, but have used it to access the router's configuration pages.

If that still has a problem, make sure the Local Area Connection has an IP address in the same Subnet (IP address range) as the router. If it doesn't, temporarily allocate a suitable fixed IP address.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?