Wi-fi laptop - limited connectivity - no DHCP

  cyberphobic 08:54 03 Mar 2006
Locked

I have an established wireless connection which works well on my 2 laptops.I have recently acquired 2 cheap laptops for my children to use (Compaq 1750s XP/SP2)and I bought 2 Waveplus Wp1200 PCMCIA wi-fi cards to use with them. The wifi network is 802.11g, the cards 802.11b. However I cannot get the cards to connect to the network, signal strength is excellent but there is limited connectivity.If I try the repair option I get the message "the following action cannot be completed - Renewing your IP address" I have followed a couple of threads on this forum and checked on event viewer and there is "no DHCP". I have also downloaded and tried WinsockXPfix without success. I'm not sure what I should do next and would appreciate some suggestions.

  mgmcc 09:23 03 Mar 2006

Some wireless routers have a setting to connect to:

- 802.11b only

- 802.11g only

- 802.11b & 802.11g

If this applies, make sure it is set for both protocols.

  mgmcc 09:27 03 Mar 2006

Also, if you have MAC address filtering enabled, check that you have entered the MAC addresses of the new WiFi adapters into the router's settings. If you are using WPA encryption, this can cause problems where router and cards are not from the same manufacturer. Try initially disabling encryption to get the cards to connect to the network.

  cyberphobic 09:44 03 Mar 2006

Thanks for those suggestions, currently at work but will try them at lunchtime and post back

  The 12th Man 15:29 03 Mar 2006

....try installing the patch on the Microsoft article KB884020.

Just go to click here and searck for the article number (KB884020). Download the patch to your desktop and then run it.

Let us know how you get on.

  cyberphobic 11:12 04 Mar 2006

Modem Router is a new D-Link DSL 504T, cannot find a setting that indicates 802.11g or 802.11b only. Have not specifically enabled MAC filtering unless it is a default setting.
Have downloaded the KB884020 patch but it doesn't solve the problem

  mgmcc 22:10 04 Mar 2006

Have you actually "Connected" to the wireless network? In other words, have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID (network name) and selected the option to "Connect" to it? Once "connected", the wireless adapter should get its IP address by DHCP from the router and you should have internet access.

If that still doesn't work, try allocating fixed addresses to the new adapters. If the router's IP address is 192.168.1.1 give the new adapters addresses such as:

IP address - 192.168.1.50 (first laptop) and 192.168.1.52 (second laptop)

Subnet Mask - 255.255.255.0 (same for both)

Default Gateway - 192.168.1.1 (the router's IP address)

DNS Server address - 192.168.1.1 (the router's IP address)

  cyberphobic 21:09 12 Mar 2006

Thanks to everyone for their suggestions for how to solve this problem. I tried everything and wasted hours, in the end I gave up and ordered 2 D-Link 802.11b cards from ebuyer (about £8 each)I installed them and they worked straight away!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?