Wi Fi with develo and android devices

  lotusallen 12:29 12 Mar 2014

I have several different android devices and until recently had no wi fi problems. My router is in the loft so i have a devolo powerline adaptor that has worked fine for several years. My broadband provider is talktalk - again i have been with them for years with no problems. Recentky i made the mistake of taking up talktalk free offer of a you view tv box. I installed this using my develo powerline adaptor. Ever since i did this my wifi network has had problems. My android devices find the network but do not acquire the ip address. If i turn my main router of and back on again all my android devices work for about half a day and then the problem reoccurs. My laptop which is a windows based machine is not affected. I have unplugged the you view box and sent it back to talktalk so everything should be back to what is was before. Both talktalk and develo say it is the others fault and nothing to do with them. Any advice would be welcome.

  abhay822 13:01 12 Mar 2014

You can try setting up static ip addresses for you Android devices the following link should help you with it click here

  lotusallen 13:41 12 Mar 2014

Can i set up static addresses for delelo powerline adaptors ? When i try this it won't let me save them .

  abhay822 15:02 12 Mar 2014

please check the configuration in the following video minutes 6.06 onwards click here need to make sure you uncheck the box which says accept network settings from dhcp server.


  lotusallen 12:06 13 Mar 2014

Thank you for that - i thought it was sorted as when i did both those procedures my tablet showed the wifi was connected. Unfortunately when i went to my browser it couldnt locate the network. Tried several apps and none eould find the internet. When i have good wifi connection my tablet shows the wifi bars in blue - when i did the above it showed them in grey.

  abhay822 13:54 13 Mar 2014

On your Android tablet I hope you have typed in the Default gateway as the IP address of your router when you configured the static IP address, the subnet mask as and DNS servers you can use are or

The following should be of help: click here you say your laptop is working ok is it connected to the router via wifi or is it connected powerline adapter using ethernet? It is most probably the former.

Can you try connecting your laptop using an ethernet cable to the powerline adapter and check if you get internet access. This should confirm whether the powerline adapter is working ok.

Also please disconnect the powerline adapter, reboot your router and check if all the devices work ok with your router in terms of internet access. This should tell you if the problem is with the router or introduction of the powerline adapter in the network causes the issue.

If the your devices work ok with the router without the powerline adapter I would suggest your reset the powerline adapter and connect it again.

If the issue seems to be with your router try the following:

Change the wireless channel to one of these : 1,6 or 9. Check for any firmware updates for your router on the Talk Talk website or forums. If everything fails contact Talk Talk hard reset your router and reconfigure it.( If you are confident doing it on your own make sure you have all the information required to configure your router).


  lotusallen 08:18 16 Mar 2014

Thank you for your help. A couple of days ago i swapped my router over for an older one that i had. Since doing this i have had no problems. I would be interested in anyones opinion as to why i suddenly had this problem on the newer router but at the moment my sytem is working fine so i am happy.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017