While initiating device IOS: Win Protection Error.

  Ben Avery (Work) 10:24 14 Feb 2003


I've been given my folks PC to take a look at (and man was there was a lot of junk on it!) as it hasn't been working too well for them.

It's a Packard Bell off-the-shelf model which they bought from Currys or Dixons (same difference) about 2 or 3 years ago. Whenever it is booted up, you get the following:

1) Single beep

2) Packard bell screen (with BIOS and POST option)

3) Single Beep

4) Windows 98 Startup screen

5) Black Screen momentarily

6) Windows 98 Startup Screen again

7) Black screen with the following error:

"While initializing device IOS:

Windows protection error. You need to restart your computer."

After pressing CTRL+ALT+DEL, it restarts and then it boots up as above but without the error screen (step 7). If you shut the PC down and then boot it up again, it boots first time, but give it a few minutes or so and it comes up with the Windows Protection Error again on startup.

I've had a look inside and removed all PCI cards and peripherals to try it and this has not helped. This happed quite some time ago and even a reinstall of windows didn't remove it.

The specs that I know of are as follows:

*GA-6WMM7 mobo (rev 4.1)

*64MB SDRAM (D'oh! I've been trying to get them to upgrade but you know Parents "They should put more in if more is needed" despite telling them that it would make everything run that much quicker with an upgrade to even 128MB!)

*Goldstar CD-RW CED-8080B

*AZT MR2800-W Data Fax Modem

*Pentium III CPU

*20GB? (showing as 15GB?) HDD

Removed components:

*2 port USB 1.1 PCI card

*Creative Soundblaster Live! 5.1 Soundcard

*USB Kodak Digital Camera

*USB HP Scanner

The soundcard is staying out as they are happy to keep onboard audio (as they don't use it!) and the card was added by me a year or so ago for a music project. Guess it'll go in my "spares" box ready for my next build for someone!

Any thoughts on how to get rid of this error?


  JoeC 10:36 14 Feb 2003
  Ben Avery (Work) 12:10 14 Feb 2003

Ok I've looked at several solutions given on the MS website links provided but there is no way that will help my problem.

As mentioned in my initial thread, this fault only occurs if the computer is left for some time. MS's solutions involve restarting in Safe Mode and seeing if the problem still occurs. Of course it didn't so I looked at the solutions given.

However, I turned it off and rebooted after a few minutes having deselected all the check boxes on the msconfig general page.

It still ran the error this time! Yet on restart it was still booting like safe mode. I have ticked the boxes again and it now boots up normally.

I know that if I leave it off for a few mins then turn on however it will cause the same error.

Is this as confusing as it sounds???


  Gongoozler 14:11 14 Feb 2003

Hi Ben. I'm posting a brief response here so that this thread will show up in "My Postings".

  Ben Avery (Work) 14:18 14 Feb 2003

Cheers buddy. I think a reinstall would be the best option in the circumstances. PB put so much junk on thier master cd's it's unreal!


  Gongoozler 20:34 14 Feb 2003

Hi Ben. I've e-mailed you my summary of your drivers, but as it was to your work address, I'll repeat the info here.

Motherboard : Gigabyte i810. - From what I can see on the Intel site, and on the GigaByte site click here all you need is the graphics driver click here and the IDE driver click here.

MR2800-W Data Fax Modem. You can get the drivers via. click here You may have to register with driverguide.com, but its free and will be useful in future.

GoldStar CD-RW. This is Plug and Play, but you will need Easy cd Creator or Nero or whatever writing software you use. You may find this on the PB disk.

WheelMouseIM (PS/2) I'm not sure who makes this, so haven't yet found the driver.

Lexmark Z22-Z32 Series. You can download the drivers from here:-
click here

  eccomputers 00:13 15 Feb 2003

when I last saw this error, I booted into safe mode, went into control panel/system and removed the ide drivers then rebooted. Windows reinstalled the drivers and it worked fine.

  Ben Avery (Work) 08:54 17 Feb 2003

Thanks Gongoozler - I'd downloaded some of them already but missed a couple so cheers. Wouldn't I also need the onboard Yamaha Sound Driver as the Creative Soundblaster Live! 5.1 isn't going back in? It was on the same site.

Eccomputers - Could you give me details on just how to go about that please?! (or anyone else)


  Gongoozler 10:34 17 Feb 2003

Hi Ben. yes if you're going to use the on-board sound driver you should download the driver for it, but you may find that Windows 98 installs it automatically.

If you want to go into safe mode to remove the ide drivers:

Click Start, and then click Shut down.
Click Restart, click OK, and then press and hold the CTRL key until the Microsoft Windows 98 Startup Menu appears. Enter the number for Safe mode, and then press ENTER.

When you are in Safe Mode, Right click on "My Computer" and select "Properties"

Select the "Device Manager" tab. Expand the "Hard disk controllers" by clicking on the + sign next to it. Select the "Primary IDE controller" and click the "Remove" button. Do the same for the "Secondary IDE controller". Then reboot.

I have never tried this procedure for the IDE controllers, but I'm pretty certain this is what eccomputers was describing.

  Ben Avery (Work) 10:27 24 Mar 2003

This is crazy but during a memory change the other day in my parents PC (they were only running 64MB of PC100) I installed a 128K PC133 and there is no Windows protection error anymore! I don't know if it was a slightly dodgy memory module but now it works lovely!.

If the cap fits... and all that!

Good old Packard Bell.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?