W2K cannot see CD/DVD drives

  zanwalk 21:49 10 Aug 2006

Rather a strange one this, I replaced the H/D on my daughter's computer, successfully imaging across from old to new - no problem. Then she discovered that she could no longer play DVD's on it. On further inspection device manager at first recognises the drives, but if you click on them it suddenly pops up with an exclamation mark, and tells me that the correct drivers are not installed. Windows Explorer doesn't recognise them at all.

Now she also has W98SE on the same H/D and that continues to work perfectly, recognising the drives normally. Nothing has been changed since the H/D swap, and I have tried uninstalling the drives and rebooting all to no avail.

Has anyone got any bright suggestions because I have run out of ideas!


  Fruit Bat /\0/\ 22:00 10 Aug 2006

Sounds like one of the W2k drivers is corrupt

Go to the manufacturer web site and download the latest drivers for W2K:

  zanwalk 22:19 10 Aug 2006

Thanks for that Fruit Bat /\0/\, I have actually tried to do that already, but found it very difficult to find the right drivers, if that is the only way, I will try again.

I would have thought that the driver files were part of the operating system on something as basic as that, and I have already done a CHKDSK /R with the installationb CD, but it didn't help.

  Fruit Bat /\0/\ 22:24 10 Aug 2006

Virtually all CDs /DVDs players and writers will use the same windows drivers in XP. they are in the windows\system32\drivers\ or windows\system32\DRIVERS \ folder and are:-





and in the windows\system32 folder


copy to a floppy or memory stick and then
try device manager update driver and install these files. to get your CD/DVD working again.
The XP drivers will probably work for w2K aswell

  zanwalk 22:32 10 Aug 2006

I'll certainly give that a go, and report back to let you know how it went.

Many thanks, I really appreciate your help.

  zanwalk 20:32 11 Aug 2006

Sadly, it hasn't worked, I tried your advice above Fruit Bat, but it didn't make any difference. I even tried uninstalling the IDE controller in Device Manager as suggested elsewhere, and on rebooting W2K found the drives again, but then declared them to have a problem. I have also tried plugging in an old CDROM I had and again it recognised it but couldn't use it.

Any more ideas anyone?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?