Vista & usb devices

  hhh123kid 17:58 19 Jan 2008
Locked

Whenever i plug in usb devices, vista doesnt recognise what im plugging in.

This also happens even if i have already managed to install the drivers for the device already.

It is especially annoying for things like ipods.

Any idea how to fix it because its driving me mad?

  BurrWalnut 18:45 19 Jan 2008

Here are some things to try :-

1. Open Computer and navigate to C:\windows\inf. Find and then right click on the hidden file INFCACHE.1, select Properties > Security Tab > Edit (to edit the permissions of the file) > Add (to add User Groups), type Administrators in the User Groups field then OK. Lastly set Administrators to Full Control and click on OK. Now move or delete the file INFCACHE.1. Finally reinstall a device so that Windows can recreate INFCACHE.1 (at this stage do not try the device that you were having issues with).

2. Unplug all USB devices except hubs, the mouse and keyboard (if you have them) then boot Windows in Safe Mode (tap F8 at switch on). Right-click Computer > Properties > Device Manager and look for everything in the USB Devices or Universal Serial Bus Controllers category then right-click and Uninstall them starting from the bottom (last one). Restart the system normally and Windows will then re-install the USB controllers. Plug in your USB devices one at a time and they should be recognised properly. Note that some drivers may be needed if Windows can't find them.

3. Read through this cumulative update rollup for USB core components as it may help click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone