Vista date and time changes every time I boot up

  [email protected] 14:58 27 Aug 2008

When I load Vista I find that the clock is at a time close to midnight (regardless of the real time) and the date has changed to 31 December 2006. This problem started about 5 or 6 weeks ago. I updated the bios and emptied CMOS and the problem ceased. During this week the problem has reappeared. I have an Abit KN9Ultra m/b, AMD Athlon 64 X2 5000+, 2 X 2 Gbyte DDR2 Twin2X memory and a 400w Akasa psu.

  Technotiger 15:09 27 Aug 2008

Sounds as if your on-board battery (CMOS battery) needs changing.

  [email protected] 10:28 29 Aug 2008

I was dubious about replacing the battery because it has only been in use since March 2007. However, I installed a new battery yesterday and all seemed OK then. When I booted up this morning it was back to 23.01 on 31/12/06. Also the Abit screen was displayed again - I normally disable it. Any other suggestions would be most welcome.

  n8-digi 11:04 29 Aug 2008

try removing all cables, opening the case and removing the battery, then hold the power button for a good 30 secs (with nothing attached) or so to drain any stale power lurking in the motherboard, reinsert the battery carefully then fire up as normal into the bios, change the time to the real time in the bios and save and exit. restart the machine into windows and set the time correctly in there too.

this worked on my HP lappy, hope it helps.

  [email protected] 13:43 29 Aug 2008

Thanks to Technotiger and n8-digi for your suggestions but the problem remains. Any other suggestions?

  [email protected] 10:17 31 Aug 2008

I discovered this morning that the ATX power plug was loose. After several restarts there has been no trouble with the clock.

  Technotiger 10:55 31 Aug 2008

Sounds like you found the culprit then. Thanks for your feedback.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

The secrets of creating gory VFX

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache