Vista can't detect modem though can talk to it

  polymath 21:11 05 May 2008

I'm trying to set up a dialup internet connection on my new laptop, using a USB modem as there isn't a port to connect directly to the phone line.

I installed the modem using its CD, Device Manager says it's working properly, and the drivers shown include the correct one from the CD. When I ask Vista to 'query' the modem, the little 'Data' light on the modem flashes, and the query comes up as successful.

But Vista says it can't set up an internet connection, because it can't detect the modem.
It's apparently on COM3, whichever of the 3 USB ports I'm trying it in (the drop-down selection list of ports has only umpteen Com ones - do Com ports include USB ones?) My mouse works in any of the USB ports.

Any ideas?

Vista Home Premium, Packard Bell Easynote BU5-R-073 laptop, Conexant (e-Tec) 56 kbps Data Fax RTAM USB modem.

  johnnyrocker 23:03 05 May 2008

one posting on same subject is all that is needed it just confuses the issue close this one and proceed with the other.


  polymath 16:27 06 May 2008

Yes I know, johnnyrocker, but I couldn't find a way to get rid of it.
Anyone know?
(My dialup connection times out easily, making searching for info sometimes impossible!).

  polymath 16:45 06 May 2008

Bluto1 suggested ticking the other posting as resolved, and I did. Hopefully it'll slip into obscurity before taking anyone else's time!

Anyone around with an idea about Vista v. the modem?

  polymath 19:47 06 May 2008

Bouncing on the offchance.....

  polymath 18:35 08 May 2008

Sorry - I got it wrong about the result of Vista querying the modem, so the thread title might be misleading. I jumped to the conclusion that I was getting a log of my modem query results, 1 result per line, with the most recent at the top. But it seems to be all from one query (results below, in case it throws any light on the subject). Vista still can't detect a dialup modem.

Another detail I remembered when reinstalling the modem again is that the modem software has seperate drivers for 'Vista' and 'Vista64'. Vaguely remembering reading about 64-bit Vista versus 32-bit, I hazarded a guess that the Vista preinstalled in PC World's computers, at least 6 months ago, would be likely 32-bit, and installed the plain 'Vista' driver. But maybe I was wrong? (Vista, on a quick foray, doesn't tell me which it is).

Result of latest modem query (from scribbling down; this kind of thing will be easier once I've got the internet connection, then downloaded the Vista driver for my printer, so I can print stuff out!).
Commands are on left, results on right.

AT#CLS=? Command not supported
AT+GCI=? +GCI: (00.07.09.OA.OF.16.1b.20.25.26 and so on (will post full version if it helps)
AT11 Success
AT12 Success
AT13 CX93001-EIS-VO.2002-V92
AT14 Success
AT15 57
AT16 Success
AT17 Success

Seems reminiscent of Basic, but I don't know what any of it means.

  polymath 21:28 08 May 2008

Can't come back till tomorrow, but any suggestions gratefully received!

  polymath 21:39 08 May 2008

Looks as if Prospero's having similar problems, click here for thread if interested.

  polymath 20:02 09 May 2008

Forgot to mention no yellow question mark on modem or anything else in Device Manager.
And that I log on to Vista as administrator(nobody else using laptop yet).
Will try Microsoft website next.

  Totally-braindead 22:44 09 May 2008

Have you actually tried to setup a manual connection? What ISP are you with?

  polymath 13:28 10 May 2008

Yes - good point, totally-unbraindead! Manual connection's actually the only kind I've tried. My ISP doesn't do a disk/download etc; connection just needs its phone number etc. (Same with my previous ISP, and its disks only used to mess things up anyway).

I'm in the Republic of Ireland, so if you're in the UK you probably don't know my ISP. UK ones are unavailable here, apart from 2 all-Ireland ones. Mine's one of those; UTV (under the umbrella of Ulster TV, our version of ITV).

I don't think my problem's ISP related; Windows hasn't got that far in the laptop, as it can't see the modem so can't create a connection. I'm using the same ISP now on the older computer, and their tech help said there won't be any problem between it and Vista.

I couldn'n't find anything by searching the Microsoft website for 'dialup modem', or anything relevant with 'USB modem'.

As I declined an extended warranty for the laptop, the manufacturer (Packard Bell) will provide support with hardware problems but not software (though they forgot that for a while re a Vista problem I had, and gave quite a lot of help!)

I only recently remembered that there's now a Vista forum here, and as I'm still tearing my hair out over this thing (it wasn't thick to start with!), I've started a similar thread there, at click here - not with so much detail but might be some help to somebody.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?